Bug #2091

Upload dialog displays incorrectly in IE

Added by Angus Griffin over 8 years ago. Updated over 8 years ago.

Status:Closed Start date:02/22/2012
Priority:Medium Due date:
Assignee:Christos Stathis % Done:

0%

Category:- Spent time: -
Target version:-

Description

Works in Firefox but not IE. See attached screenshot.

pithos-upload-dialog-ie.PNG (27.3 kB) Angus Griffin, 02/22/2012 11:47 pm

7F4E5C0170BF528A568EA93688F1C7C0.cache.htm Magnifier (835.9 kB) Angus Griffin, 02/24/2012 09:35 am

History

#1 Updated by Christos Stathis over 8 years ago

  • Status changed from New to Assigned
  • Assignee set to Christos Stathis

Could you please provide more details cause I cannot reproduce the problem ? Did you test on plus.pithos.grnet.gr or pithos.dev.grnet.gr ? What version IE/Windows do you use? Do you have any of the following plugins on IE ? flash, gears, silverlight ? Sometimes, when using any of these plugins, it takes some time to download the corresponding files from the server, so the dialog appears empty but after a while it is initialized correctly.

#2 Updated by Angus Griffin over 8 years ago

Yes tested on pithos.dev.grnet.gr, same as on my local build.

Dialog displays correctly in Chrome as well as FF - tested today.

Problem is exhibited in Windows 7 and IE9. Tested on two computers. Will test on IE8 Win Vista tonight.

After putting IE9 into IE8 or IE7 compatibility mode (via F12 developer tools), the upload dialog shows correctly. Actually, even still in IE9 mode, if you hit F12 to show the developer tools and don't change anything, the dialog shows correctly! Very weird... could be an IE bug?

I have flash only installed. Doesn't seem to matter how long I wait however, the dialog never shows correctly.

If I catch the error, I get
SCRIPT5022: Exception thrown and not caught
7F4E5C0170BF528A568EA93688F1C7C0.cache.html, line 2094 character 75

Have attached that file.

function Ed(b){return function(){try{return Fd(b,this,arguments)}catch(a){throw a}}}

#3 Updated by Christos Stathis over 8 years ago

The code is obfuscated by the compiler. I have uploaded a non-obfuscated version on the server. Please try once more, catch the error and attach the file again. That will help locating the error.

#4 Updated by Panagiotis Kanavos over 8 years ago

I see the same behavior using IE9 on Windows 2008 R2. The problem is solved by switching to compatibility view.
Additionally, the problem doesn't appear when Dev Tools are activated and the page refreshed, even if no changes are made to the default settings.

Perhaps IE9 decides to render the page before the upload UI script is downloaded. The Dev Tools force all scripts to download before rendering the page which may account for the different behavior when Dev Tools are active

#5 Updated by Kostas Papadimitriou over 8 years ago

I can confirm the bug on windows7/IE9.

It seems though that having developer tools window open causes the upload overlay to render properly. I have experienced the same behavior in the past while using the window.console object to log javascript messages. The object is not available in IE9 if developer tools window is closed [1].

[1] http://stackoverflow.com/questions/5472938/does-ie9-support-console-log-and-is-it-a-real-function

#6 Updated by Panagiotis Kanavos over 8 years ago

I had problems with the Console object in the past as well. As the SO answer says, there is no real standard on how the console object behaves.

I've used the following check in the past (in a Silverlight app) to check for the existence of the console before calling log:

typeof(console)!= 'undefined' && typeof (console.log) != 'undefined'

I've found other differences as well which were specific to SL and Chrome. I don't think they would matter here

#7 Updated by Christos Stathis over 8 years ago

Fixed in 3aa012b0e7c3440f9bb55dc9e6caa1a1a7c84121
It was the console.log IE issue

#8 Updated by Christos Stathis over 8 years ago

  • Status changed from Assigned to Resolved

#9 Updated by Christos Stathis over 8 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF