Bug #2172

Retrieve credentials no longer works

Added by Angus Griffin over 7 years ago. Updated over 7 years ago.

Status:Closed Start date:03/07/2012
Priority:Medium Due date:
Assignee:- % Done:

0%

Category:- Spent time: -
Target version:-

Description

While retrieve credentials used to work for me, it no longer seems to.

The tcp port referred to in the URL (e.g. 65038) is opened by the ms client, but I enter my login/password in astakos and either:

a) the sessions seems to time out; or
b) I can log in but the ms client shows a dialog "An error occurred while retrieving credentials"

The connection between the browser and the ms client seems to be successful, shown by the below netstat output:
C:\Users\angus.griffin>netstat -an |grep 65038
TCP 0.0.0.0:65038 0.0.0.0:0 LISTENING
TCP 127.0.0.1:65038 127.0.0.1:65069 ESTABLISHED
TCP 127.0.0.1:65038 127.0.0.1:65070 ESTABLISHED
TCP 127.0.0.1:65069 127.0.0.1:65038 ESTABLISHED
TCP 127.0.0.1:65070 127.0.0.1:65038 ESTABLISHED

Note that I am not running the latest server software (either pithos or astakos) at present as I am waiting for updated installation documentation to be completed.


Related issues

related to Pithos MS Client - Bug #2011: Exception thrown when Astakos doesn't return an expected ... Closed 02/07/2012
related to Pithos MS Client - Bug #2006: exception when unable to retrieve credentials Closed 02/07/2012
related to Pithos MS Client - Feature #1567: Handle both 401 and 403 errors when authentication fails Closed 10/24/2011

History

#1 Updated by Angus Griffin over 7 years ago

This is specific to the (out of date) AARNet install.

Please disregard this bug report.

#2 Updated by Panagiotis Kanavos over 7 years ago

  • Status changed from New to Closed

The issue is caused by an IE's faulty handling of multiple redirects (302). In some cases IE will fail to perform the last redirect. This causes issues because authentication against Shiboleth requires at two redirects (from Astakos to Pithos, from Pithos to the local port).

Solved by using a web browser hosted in an application page, thus bypassing IE's faulty behavior.

Also available in: Atom PDF