Bug #2287

Drag and drop a single text file results in stuck hashing

Added by Panagiotis Louridas about 7 years ago. Updated almost 7 years ago.

Status:Closed Start date:04/03/2012
Priority:High Due date:
Assignee:Panagiotis Kanavos % Done:

0%

Category:Core Spent time: -
Target version:Alpha

Description

I create a text file on the desktop, say test.txt, then I drag and drop it in the Pithos folder. The client displays "Hashing [test.txt]", but never syncs it, and never progresses beyond that.

If I do that with a second text file, say test1.txt, then the client displays "Hasing [test1.txt]", again without syncing it, and again never progressing beyond that (unless I do that with a third text file, and so on).

History

#1 Updated by Panagiotis Kanavos about 7 years ago

  • Category set to Core
  • Status changed from New to Feedback
  • Target version set to Alpha

Can't reproduce with a non-empty file. I can reproduce this behavior with an empty file.

#2 Updated by Panagiotis Kanavos about 7 years ago

  • Status changed from Feedback to Resolved

Fixed by properly handling empty files during upload

#3 Updated by Panagiotis Kanavos almost 7 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF