Bug #717

Διόρθωση μικρών bugs στο UI

Added by Vangelis Koukis almost 11 years ago. Updated almost 11 years ago.

Status:Closed Start date:07/03/2011
Priority:High Due date:
Assignee:Kostas Papadimitriou % Done:

0%

Category:Cyclades UI Spent time: -
Target version:v0.5.1

Description

Στο ticket αυτό θα καταγράφονται όλα τα μικρά bugs που πρέπει να διορθωθούν στον κύκλο διορθώσεων για v0.5.1.
Αν κάτι αποδειχθεί μεγαλύτερο, είτε αναβάλλεται είτε ανοίγει σε χωριστό ticket.

Associated revisions

Revision 3b84b94a
Added by Kostas Papadimitriou almost 11 years ago

vms view select tooltips, Refs #717

History

#1 Updated by Vangelis Koukis almost 11 years ago

(1) Όταν ένα μηχάνημα είναι building, αν πάω στα δίκτυα σκάει λάθος, μάλλον από uncaught exception. Για replication: "Create New +" και αμέσως μετά κλικ στο networks tab.

(2) Όταν έρχεται async notification ότι ένα μηχάνημα είναι Rebooting, δεν κάνει μετάβαση μουσταρδί + spinner. Για replication: ανοίγω δύο παράθυρα, στο ένα προκαλώ reboot σε VM, στο άλλο γίνεται "Rebooting" και τα λαμπάκια μένουν πράσινα.

(3) Κάτι δεν πάει καλά με το Connect. Σε χθεσινές δοκιμές μου, κάποια στιγμή σβήνοντας-ανάβοντας μηχανήματα, το UI προσπαθούσε να με connect σε λάθος μηχάνημα, διαφορετικό από αυτό που πατούσα. Δεν μπορώ να το κάνω replicate αξιόπιστα. Μπορεί να επιβεβαιωθεί ότι το μηχάνημα του οποίου την IP και του οποίου τα metadata κοιτάζει για να κάνει "connect" παραμένουν σωστά καθώς σβήνεις μηχανήματα, κλπ;

Αυτά βλέπω προς το παρόν...

#2 Updated by Vangelis Koukis almost 11 years ago

Κι άλλο ένα, αρχίζουν να προστίθενται: υπάρχουν θέματα με Firefox 3.x, δεν παίζει καθόλου το refresh του UI, για κάποιο λόγο πετάει μήνυμα λάθους, πάλι μάλλον κάποιο unhandled exception.

#3 Updated by Kostas Papadimitriou almost 11 years ago

Vangelis Koukis wrote:

Κι άλλο ένα, αρχίζουν να προστίθενται: υπάρχουν θέματα με Firefox 3.x, δεν παίζει καθόλου το refresh του UI, για κάποιο λόγο πετάει μήνυμα λάθους, πάλι μάλλον κάποιο unhandled exception.

Λογικά έχει λυθεί με το a657c49

#4 Updated by Kostas Papadimitriou almost 11 years ago

Vangelis Koukis wrote:

(1) Όταν ένα μηχάνημα είναι building, αν πάω στα δίκτυα σκάει λάθος, μάλλον από uncaught exception. Για replication: "Create New +" και αμέσως μετά κλικ στο networks tab.

d6579fa

(2) Όταν έρχεται async notification ότι ένα μηχάνημα είναι Rebooting, δεν κάνει μετάβαση μουσταρδί + spinner. Για replication: ανοίγω δύο παράθυρα, στο ένα προκαλώ reboot σε VM, στο άλλο γίνεται "Rebooting" και τα λαμπάκια μένουν πράσινα.

1df6352

όπως αναφέρω και στο commit msg στο list view υπήρχαν προβλήματα σε περισσότερα state transitions. θα λυθούν σε ξεχωριστό commit.

(3) Κάτι δεν πάει καλά με το Connect. Σε χθεσινές δοκιμές μου, κάποια στιγμή σβήνοντας-ανάβοντας μηχανήματα, το UI προσπαθούσε να με connect σε λάθος μηχάνημα, διαφορετικό από αυτό που πατούσα. Δεν μπορώ να το κάνω replicate αξιόπιστα. Μπορεί να επιβεβαιωθεί ότι το μηχάνημα του οποίου την IP και του οποίου τα metadata κοιτάζει για να κάνει "connect" παραμένουν σωστά καθώς σβήνεις μηχανήματα, κλπ;

7acbe201

Αυτά βλέπω προς το παρόν...

#5 Updated by Vangelis Koukis almost 11 years ago

  • Status changed from Assigned to Closed

Αυτά είναι εντάξει, για τα επόμενα ανοίγουμε άλλο ticket ώστε να καταγραφεί χωριστά και να μπορούμε να το βρίσκουμε ευκολότερα...

Also available in: Atom PDF