Bug #779

logic/dispatcher does not daemonize properly

Added by Vangelis Koukis almost 11 years ago. Updated almost 11 years ago.

Status:Closed Start date:07/08/2011
Priority:Medium Due date:
Assignee:Giorgos Gousios % Done:

100%

Category:logic Spent time: -
Target version:v0.5.1

Description

Something seems to be wrong, the dispatcher dies if the controlling terminal dies, even when it's supposed to have daemonized.

Associated revisions

Revision e639edf9
Added by Giorgos Gousios almost 11 years ago

Default log configuration: syslog on Linux

Refs: #779

History

#1 Updated by Giorgos Gousios almost 11 years ago

The situation is as follows:

-On the Mac the bug report is accurate, when the terminal process that starts the dispatcher goes away, the dispatcher dies when the first msg is received from the queue
-On Linux, the dispatcher process does not die when the controlling terminal dies. Instead, it cannot report any logging messages.

The root cause seems to be the fact that the logging module was configured to write the log messages to stdout by default, so when it cannot write to it because the console stream is dead, it will fail, in a system dependent way

To solve this, we decided to just use sensible defaults for logging: syslog on Linux. Users (incl Mac users) wanting to override this behaviour can copy/configure the logging.conf file to the directory from which they start the dispatcher.

#2 Updated by Giorgos Gousios almost 11 years ago

  • % Done changed from 0 to 100

#3 Updated by Giorgos Gousios almost 11 years ago

Added some documentation in revision 3a4e3bac

#4 Updated by Vangelis Koukis almost 11 years ago

  • Status changed from New to Closed

Closing ticket.

Also available in: Atom PDF