Bug #813

Minor UI issues

Added by Vangelis Koukis almost 11 years ago. Updated almost 11 years ago.

Status:Closed Start date:07/13/2011
Priority:Medium Due date:
Assignee:Kostas Papadimitriou % Done:

0%

Category:Cyclades UI Spent time: -
Target version:v0.5.4

Description

A list of assorted minor features:
  • All transitional states should have "..." appended after their name, e.g. "Shutting down...", "Starting...", "Destroying...", etc.
  • caption "invitations" should read "invite people...", caption "feedback" should read "send us feedback!"
  • sometimes when a machine goes in "ERROR" state it gets a dark red set of LEDs instead of the bright red ones

Associated revisions

Revision 6dd01959
Added by Kostas Papadimitriou almost 11 years ago

Append "..." on machine transitional states, Refs #813

Revision 69ba1fcf
Added by Kostas Papadimitriou almost 11 years ago

Machine status indicator update fix, Refs #813

Fixed display of the proper indicator image when a machine
transits from an active state to ERROR state.
Fixes apply for both icon and single view.

History

#1 Updated by Kostas Papadimitriou almost 11 years ago

After a quick review on transitions text representations, it seems that hardcoded conditions with the default (english) texts exist in several places within the code.

E.g.

ui/templates/machines_icon.html

// current_message now includes the content of the status div (translated in current request language)
546: var current_message = existing.find(".status").text();

// current_message property won't exist if transition is translated in another language
609: else if ((TRANSITIONS[current_message] == 'Rebooting' && server.status == 'ACTIVE') || ...

// TRANSITIONS defined in ui/templates/home.html
 91         var TRANSITIONS = {
 92             'Shutting down' : '{% trans "Shutting down" %}',
 93             'Rebooting'     : '{% trans "Rebooting" %}',
 94             'Starting'      : '{% trans "Starting" %}',
 95             'Destroying'    : '{% trans "Destroying" %}',
 96             'Connecting'    : '{% trans "Connecting" %}',   // used only in networks
 97             'Disconnecting' : '{% trans "Disconnecting" %}' // used only in networks
 98         };

it seems like a non-trivial, at least without further review of the code.

#2 Updated by Vangelis Koukis almost 11 years ago

  • Target version changed from v0.5.1 to v0.5.2

Moving to v0.5.2...

#3 Updated by Vangelis Koukis almost 11 years ago

A few more problems:

  • IE8/9 does not update the Single-server view properly, seems to be stuck in "Building"
  • IE shows "Destroy" out of alignment when it is the only available option.

#4 Updated by Vangelis Koukis almost 11 years ago

  • Status changed from New to Assigned

#5 Updated by Kostas Papadimitriou almost 11 years ago

Vangelis Koukis wrote:

  • IE shows "Destroy" out of alignment when it is the only available option.

Fixed on 5b78090

#6 Updated by Vangelis Koukis almost 11 years ago

  • Subject changed from Minor UI issues for v0.5.1 to Minor UI issues

#7 Updated by Vangelis Koukis almost 11 years ago

  • Target version changed from v0.5.2 to v0.5.3

#8 Updated by Vangelis Koukis almost 11 years ago

  • Target version changed from v0.5.3 to v0.5.5

#9 Updated by Vangelis Koukis almost 11 years ago

  • Target version changed from v0.5.5 to v0.5.4

#10 Updated by Kostas Papadimitriou almost 11 years ago

  • Status changed from Assigned to Feedback

it seems like a non-trivial, at least without further review of the code.

A workaround solution to fix the issue is committed on 6dd0195.

#11 Updated by Kostas Papadimitriou almost 11 years ago

sometimes when a machine goes in "ERROR" state it gets a dark red set of LEDs instead of the bright red ones

fixed on 69ba1fc

#12 Updated by Vangelis Koukis almost 11 years ago

  • Status changed from Feedback to Closed

Fix merged, closing.

Also available in: Atom PDF