Statistics
| Branch: | Tag: | Revision:

root / INSTALL @ 756df409

History | View | Annotate | Download (5.8 kB)

# Date Author Comment
7578ab0a 04/18/2011 06:55 pm Michael Hanselmann

qlang: Add parser for query filter language

With this parser, command line utilities will be able to provide filters
through query2 in a simplistic language. Example filters:

name  "node3.example.com" 
master or (name "node4.example.com")
be/memory == 128 and name =~ /^web/i...
1ebe6dbd 03/31/2011 12:02 pm Iustin Pop

Improve references to htools in the documentation

Was not sure about the bit in admin.rst, hope it's fine.

Signed-off-by: Iustin Pop <>
Reviewed-by: René Nussbaumer <>

77a180f6 03/23/2011 01:25 pm Iustin Pop

Update INSTALL and devnotes.rst with Haskell notes

This documents the needed libraries for Haskell development. It also
fixes a tiny typo in devnotes.rst.

Signed-off-by: Iustin Pop <>
Reviewed-by: Michael Hanselmann <>

e90739d6 11/10/2010 08:53 pm Michael Hanselmann

impexpd: Disable OpenSSL compression in socat if possible

This uses an option only available in patched socat versions. More
information is available from the INSTALL update included in this
patch.

Signed-off-by: Michael Hanselmann <>
Reviewed-by: Guido Trotter <>

69affe73 08/19/2010 04:02 pm Manuel Franceschini

Document primary ip version and ndisc6

Signed-off-by: Manuel Franceschini <>
Reviewed-by: Iustin Pop <>

a40b1fc4 07/20/2010 12:34 pm René Nussbaumer

Adding new (optional) dependency to configure.ac

Signed-off-by: René Nussbaumer <>
Reviewed-by: Michael Hanselmann <>

801b6a33 07/01/2010 05:31 pm Guido Trotter

Merge branch 'stable-2.1'

  • stable-2.1:
    Bump up version for 2.1.5 release
    RapiClient: fix multi-authentication in Python 2.6
    Remove rapi-user and rapi-pass from qa-sample.json
    qa: fix gnt-instance modify -t drbd
    qa: shutdown instance before trying disk convert...
2a7c3583 07/01/2010 03:13 pm Michael Hanselmann

RAPI client: Switch to pycURL

Currently the RAPI client uses the urllib2 and httplib modules from
Python's standard library. They're used with pyOpenSSL in a very fragile
way, and there are known issues when receiving large responses from a RAPI
server.
...

b447ab51 06/30/2010 03:48 pm Luca Bigliardi

Document optional ctypes dependency

Signed-off-by: Luca Bigliardi <>
Reviewed-by: Guido Trotter <>

e0897adf 06/09/2010 12:40 pm Michael Hanselmann

Start to prepare documentation for 2.2 release

- Update NEWS file
- Remove dependency on OpenSSL (pyOpenSSL remains)
- Update manpages, fix typos and other things

Signed-off-by: Michael Hanselmann <>
Reviewed-by: Iustin Pop <>

c4b2b2e2 05/12/2010 01:48 pm Guido Trotter

INSTALL: update hypervisor requirements

Xen: Just specify 3.0 or above as a requirement, as versions above 3.1
have been tested and work fine with Ganeti. Also note that the Xen
dependency is optional, if one wants to work with KVM.

KVM: list as an alternative, specify that 72 (the one shipped with...

c27ba1cc 11/13/2009 05:59 pm Michael Hanselmann

Convert INSTALL to RST

This is in preparation to including it into the large
documentation.

Signed-off-by: Michael Hanselmann <>
Reviewed-by: Guido Trotter <>

d17e74b4 05/12/2009 02:29 pm Iustin Pop

Switch the documentation to sphinx

This big patch converts the documentation build system to sphinx
(http://sphinx.pocoo.org/). Since that uses reStructuredText sources
too, there is no change (yet) in the documents themselves, just in the
build system.
...

ffa1c260 10/02/2008 01:22 pm Michael Hanselmann

Remove references to Twisted framework

Reviewed-by: iustinp

39e0d19e 08/25/2008 05:56 pm Michael Hanselmann

Remove references to YAML

I forgot to remove these when converting the QA configuration from YAML
to JSON.

Reviewed-by: ultrotter

bd028152 05/29/2008 12:59 pm Iustin Pop

Documentation: cleanup of local/remote_raid1

Since we have removed support for local and remote raid1, update the man
pages and guides to reflect the new situation.

Reviewed-by: imsnah

bb987157 12/17/2007 04:50 pm Iustin Pop

Make note about minimum version of drbd 8 required

Since 8.0.6 and lower have issues that break Ganeti's usage of drbd,
this patch notes the required version of DRBD.

Reviewed-by: ultrotter

6c4811dc 11/12/2007 03:19 am Iustin Pop

Update documentation for drbd8 and beta2 release

This patch does:
- add drbd8 information to the docs (the new disk template, examples,
etc.)
- fixes a section header to make it more clear
- update the NEWS file by changing format (format taken by looking at...

a2cfdea2 10/24/2007 04:30 pm Iustin Pop

Add DRBD8 class for handling drbd version 8.x

This duplicates some code from the DRBDev class, but not very much, and
it will be expanded with the new functionality available for the 8.x
version. Currently the code is not accessible outside the module.

This patch introduces a dependency on the pyparsing module....

16abfbc2 10/10/2007 08:20 pm Alexander Schreiber

Remove fping as a dependency for Ganeti.

This patch completely gets rid of fping
- replace all fping invocations with TcpPing calls
- update documentation accordingly.
- associated cleanups (use constant for localhost IP, use more sensible
defaults for TcpPing and use those)...

319856a9 10/04/2007 02:33 pm Michael Hanselmann

Change configuration storage format from Pickle to JSON.

- Add NEWS file with major changes between versions.
- Bump RPC version number
- No longer serialize in RPC, but just convert to dict

Old Pickle based configuration files can be converted using the cfgupgrade...

bd205d0e 09/04/2007 04:10 pm Michael Hanselmann

Now that we use configure's variables, add --sysconfdir to configure.

Reviewed-by: ultrotter

04daec5d 09/03/2007 04:23 pm Michael Hanselmann

- Rename docs/ to doc/
- Add Makefile in doc/examples/

Reviewed-by: schreiberal

4096472d 08/27/2007 12:20 pm Iustin Pop

Changed INSTALL to point to the tutorial and admin guide.

b212bf8b 08/21/2007 11:39 am Iustin Pop

Rename installing.sgml to install.sgml

This is more in line with the other document names.

Also, change the title to simply "Ganeti installation tutorial".

Reviewed-by: ultrotter

5cd0d9c0 08/20/2007 05:43 pm Iustin Pop

Add information about installing from source.

In case one installs from source, make, tar and gzip are also needed. tar and
gzip are almost always installed, but make not, so let's add a note about that.

Also remove a '>' in the apt-get install example so copy-paste works....

1005b0c1 08/16/2007 06:23 pm Iustin Pop

Another documentation update.

This removes the section on packages from installing.sgml (until we have
packages) and adds/corrects informations about using the startup script.

It also adds notes about the ``--master-netdev`` option, which one needs
to use if the node doesn't have an interface named xen-br0 (or if it's...

a7a19281 08/16/2007 04:06 pm Iustin Pop

Documentation updates.

This changes installing.sgml, adding details about required software and
OS instances. It also updates INSTALL and README to correspond with the
sgml manual.

Reviewed-by: ultrotter

bd785ecd 07/18/2007 12:44 pm Michael Hanselmann

Fix casings of program names, add URLs, add info about PyYAML.

Reviewed-by: iustinp

7f2778e7 07/17/2007 03:50 pm Alexander Schreiber

added drbd to list of requirements listed in INSTALL file

Reviewed-by: iustinp

a8083063 07/16/2007 04:39 pm Iustin Pop

Initial commit.