Revision 817711e5 docs/conf.py

b/docs/conf.py
67 67
        from objpool.http import PooledHTTPConnection
68 68
        PooledHTTPConnection
69 69
    except ImportError:
70
        stderr.write("`objpool` package is required to build kamaki docs.\n")
70
        stderr.write('`objpool` package is required to build kamaki docs.\n')
71
        exit(1)
72

  
73

  
74
try:
75
    from astakosclient import AstakosClient
76
    AstakosClient
77
except ImportError:
78
    path.insert(0, '%s/%s' % (
79
        SITE_PACKAGES_PATH,
80
        'astakosclient-0.14.5next_10224_6c10f58-py2.7.egg'))
81
    try:
82
        from astakosclient import AstakosClient
83
        AstakosClient
84
    except ImportError:
85
        stderr.write(
86
            '`astakosclient` package is required to build kamaki docs.\n')
71 87
        exit(1)
72 88

  
73 89
# try:
......
79 95
#         from progress.bar import ShadyBar
80 96
#         ShadyBar
81 97
#     except ImportError:
82
#         stderr.write("`progress` package is suggested to build kamaki docs.\n")
98
#         stderr.write(
99
#           '`progress` package is suggested to build kamaki docs.\n')
83 100

  
84 101
path.insert(0, os.path.join(os.path.abspath(os.path.dirname(__file__)), '..'))
85 102

  

Also available in: Unified diff