Revision 961e6040 docs/installation.rst

b/docs/installation.rst
16 16
Installing from source (git repos.)
17 17
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
18 18

  
19
Requirements
20
""""""""""""
21

  
22
Essential:
23

  
24
 * Python 2.6 or better [http://www.python.org]
25
 * Python setuptools [http://pypi.python.org/pypi/setuptools]
26

  
27
Optional:
28

  
29
 * VirtualEnv (python-virtualenv) [http://www.virtualenv.org]
30

  
19 31
1. Setup a virtual enviroment (optional)
20 32
""""""""""""""""""""""""""""""""""""""""
21 33

  
......
27 39

  
28 40
    $ source kamaki-env/bin/activate
29 41

  
30
.. hint:: More about virtualenv: `<http://www.virtualenv.org>`_
42
A more detailed example of using virtual env can be found at the `snf-image-creator setup guide <http://docs.dev.grnet.gr/snf-image-creator/latest/install.html#python-virtual-environment>`_
31 43

  
32
2. Install snf-common from synnefo project (required since v0.6.0)
33
""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""
44
2. Install snf-common
45
"""""""""""""""""""""
34 46

  
35
Package snf-common is required since kamaki 0.6.0.
47
Package snf-common is part of the synnefo project and is a kamaki dependency since version 0.6.0.
36 48

  
37 49
.. code-block:: console
38 50

  

Also available in: Unified diff