Statistics
| Branch: | Revision:

root / ui @ 3bbbee18

Latest revisions

# Date Author Comment
3bbbee18 06/14/2011 04:08 am Andreas Färber

cocoa: Provide central qemu_main() prototype

This fixes a missing prototype warning in vl.c and obsoletes
the prototype in cocoa.m. Adjust callers in cocoa.m to supply
third argument, which is currently only used on Linux/ppc.

The prototype is designed so that it could be shared with SDL...

9851484f 06/14/2011 04:08 am Alexandre Raymond

Cocoa: avoid displaying window when command-line contains '-h' or '-help'

There was already a check in place to avoid displaying a window
in certain modes such as vnc, nographic or curses.

Add a check for '-h' and '-help' to avoid displaying a window for a split-...

e4ebcc1a 06/14/2011 04:08 am Tristan Gingold

cocoa: do not create a spurious window for -version

When invoked with -version, qemu will exit just after displaying the version,
so there is no need to create a window.
Also handles --XXX options.

Signed-off-by: Tristan Gingold <>
Signed-off-by: Andreas Färber <>

ac779fe2 06/08/2011 08:15 pm Anthony Liguori

Merge remote-tracking branch 'spice/spice.v37' into staging

Conflicts:
vl.c

9bf0960a 06/08/2011 11:04 am Alexandre Raymond

Fix compilation warning due to missing header for sigaction (followup)

This patch removes all references to signal.h when qemu-common.h is included
as they become redundant.

Signed-off-by: Alexandre Raymond <>
Signed-off-by: Stefan Hajnoczi <>

d4970b07 06/06/2011 10:14 am Hans de Goede

spice: add option for disabling copy paste support

Some people want to be able disable spice's guest <-> client copy paste support
because of security considerations.

[ kraxel: drop old-version error message ]

48b3ed0a 06/06/2011 10:14 am Marc-André Lureau

spice: add SASL support

Turn on SASL support by appending "sasl" to the spice arguments, which
requires that the client use SASL to authenticate with the spice. The
exact choice of authentication method used is controlled from the
system / user's SASL configuration file for the 'qemu' service. This...

012b80d3 06/06/2011 10:14 am Gerd Hoffmann

spice: require spice 0.6.0 or newer.

This patch raises the minimum required spice version to 0.6.0 and drops
a few ifdefs.

0.6.0 is the first stable release with the current libspice-server API,
there shouldn't be any 0.5.x development versions deployed any more....

1de9756b 05/15/2011 02:05 am Michael Tokarev

set $SDL_VIDEODRIVER=x11 on Linux to prevent sudo kvm from fighting for video card

Signed-off-by: Michael Tokarev <>
Acked-by: Alexander Graf <>
Signed-off-by: Aurelien Jarno <>

196a7784 05/03/2011 04:35 pm Gerd Hoffmann

spice: drop obsolete iothread locking

We don't use qemu internals from spice server context any more.
Thus we don't also need to grab the iothread mutex from spice
server context. And we don't have to temporarely release the
lock to avoid deadlocks. Drop all the calls....

View revisions

Also available in: Atom