Statistics
| Branch: | Tag: | Revision:

root / configure.ac @ 13d26b66

History | View | Annotate | Download (24.9 kB)

# Date Author Comment
5fd32824 02/24/2014 05:44 pm Klaus Aehlig

Merge branch 'stable-2.11' into master

  • stable-2.10
    Let the instance's tuple of nodes start with the primary
    Fix the test that checks for the order of instance's nodes
    Revision bump for the 2.10.0 release
    Update NEWS file for 2.10.0
    Revision bump for 2.10.0~rc3...
9b6d2d92 02/24/2014 01:50 pm Petr Pudlak

Compile every Haskell object file separately

This allows parallel compilation of all targets, including the Haskell
object files. While re-starting GHC for every Haskell source almost
doubles the total CPU time, allowing it run in parallel at the end cuts...

1551758e 02/24/2014 01:50 pm Petr Pudlak

Add configuration options for Haskell compilation variants

Previously this was addressed by Makefile variables, which meant that
it was possible to build the same binary with different compilation
options without recompiling.

Signed-off-by: Petr Pudlak <>...

e63e8891 02/24/2014 09:49 am Petr Pudlak

Configure luxid to run with the same user as masterd

Currently masterd and luxid run under separate user accounts, which
makes it impossible for them to share access to the job queue.
This patch adds the easiest fix - to configure luxid to run under the
same user as masterd....

fb0fa957 02/14/2014 11:47 am Petr Pudlak

Add the WConfD daemon to build configuration files

Also list it in the Haskell datatype, constants, Python constants and
test configuration.

Signed-off-by: Petr Pudlak <>
Reviewed-by: Klaus Aehlig <>

fb1a5271 02/14/2014 11:46 am Petr Pudlak

Add dependencies for lifted-base to build_chroot

.. for both Debian distribution. Also check that the library is present
during the configuration step.

Signed-off-by: Petr Pudlak <>
Reviewed-by: Klaus Aehlig <>

bcb1ab78 02/12/2014 05:54 pm Petr Pudlak

Merge branch 'stable-2.11' into master

  • stable-2.11
    Update the list dependencies in INSTALL
    Make luxid's Haskell dependencies mandatory
    Fix start/stop scripts to run luxid unconditionally
    Remove the HTOOLS configuration variable
    Add a config. conditional for running Haskell coverage...
f4445f53 02/12/2014 05:27 pm Petr Pudlak

Make htools and luxid mandatory in the Makefile

Since Ganeti now uses luxid for core operations, it needs to be always
present.

Signed-off-by: Petr Pudlak <>
Reviewed-by: Helga Velroyen <>

eb84bb80 02/12/2014 05:27 pm Petr Pudlak

Add a config. conditional for running Haskell coverage

Similarly to PY_UNIT, add HS_UNIT to run Haskell coverage only if we
have the required modules.

Signed-off-by: Petr Pudlak <>
Reviewed-by: Helga Velroyen <>

636e66d1 02/12/2014 05:27 pm Petr Pudlak

Make luxid's Haskell dependencies mandatory

in the build configuration files.

Signed-off-by: Petr Pudlak <>
Reviewed-by: Helga Velroyen <>

3af1359f 02/06/2014 03:34 pm Jose A. Lopes

Add metadata daemon

... including, user, group, daemonizing code with command line
options, integration with the Snap HTTP server, and logic.

Signed-off-by: Jose A. Lopes <>
Reviewed-by: Michele Tartara <>

8d61946f 01/30/2014 11:03 am Petr Pudlak

Merge branch 'stable-2.11' into master

  • stable-2.11
    Make safeRenameFile create dirs with defined permissions
    Add constant for subdir permissions within the job queue
    Add utility to fix permissions
    Add data type describing permissions and possibly owners...
baaa2ece 01/28/2014 03:17 pm Klaus Aehlig

Merge branch 'stable-2.10' into stable-2.11

  • stable-2.10
    Enable network tags in Haskell code
    Haskell style: explicit errors, visible in the type
    Clarify spacing in record syntax
    Improve the point-free section of the style guide
    Add code style document to documentation...
410945f1 01/27/2014 05:36 pm Klaus Aehlig

Merge branch 'stable-2.9' into stable-2.10

  • stable-2.9
    Revision bump for 2.9.3
    Schedule 2.9.3 release
    Document fix of issue 691 in NEWS
    NEWS: fix typo in 2.8.4 release
    Fix 'hvparams' of '_InstanceStartupMemory' on hypervisors
    Add missing option to gnt-instance documentation...
8dba1797 01/27/2014 11:18 am Klaus Aehlig

Revision bump for 2.9.3

Signed-off-by: Klaus Aehlig <>
Reviewed-by: Jose Lopes <>

ae6a0a7c 01/17/2014 12:29 pm Jose A. Lopes

Fix configure dirs

Fix overridable configure directories, namely, --bindir, --sbindir,
and --mandir.

Variables 'bindir', 'sbindir', and 'mandir' are exported from
'configure.ac' to 'Makefile.am'. At first, it would seem to be
possible to do the following:...

c777c5fc 01/16/2014 02:15 pm Helga Velroyen

Prepare master as new 2.12 branch

This adapts various file to make the current master
branch the new stable-2.12 branch.

Signed-off-by: Helga Velroyen <>
Reviewed-by: Guido Trotter <>

4084d18f 01/13/2014 07:43 pm Jose A. Lopes

KVM daemon datatype, user and group

  • add user and group to 'configure.ac', 'Makefile.am' and
    'AutoConf.hs.in'
  • extend 'Daemon' datatype with 'GanetiKvmd' and implement all related
    functions, such as, 'daemonName', etc.
  • export KVM daemon name as constant...
47387ccb 01/13/2014 03:39 pm Klaus Aehlig

Break line longer than 80 chars in configure.ac

Signed-off-by: Klaus Aehlig <>
Reviewed-by: Jose Lopes <>

a347cdc6 01/13/2014 02:16 pm Apollon Oikonomopoulos

configure: allow detection of Sphinx 1.2+

The regular expression used for parsing the Sphinx version does not work
with Sphinx versions after 1.1, as reported in issue #502. The reason
for this is that upstream commit 8f28af8e2ed81 introduced proper
support for --version, which ganeti was already using but sphinx-build...

a5c50971 12/16/2013 05:53 pm Thomas Thrainer

Version bump for 2.10.0~rc1

Signed-off-by: Thomas Thrainer <>
Reviewed-by: Michele Tartara <>

89c63fbe 12/13/2013 03:09 pm Klaus Aehlig

Bump revision for 2.9.2

Signed-off-by: Klaus Aehlig <>
Reviewed-by: Michele Tartara <>

6b95cc5e 11/26/2013 07:12 pm Klaus Aehlig

Document the minimal version of base64-bytestring required

There exist several versions of base64-bytestring; the interface we're
using is that of version 1.0.0.0 or higher.

Signed-off-by: Klaus Aehlig <>
Reviewed-by: Helga Velroyen <>

7afed8fe 11/26/2013 03:31 pm Klaus Aehlig

Add zlib and base64-bytestring as haskell dependencies

With luxid taking over more and more job management, replicating job
files should use the compressed option, as is currently done by masterd.
This requires gzip compression and base64 encoding available in haskell...

0dfd65e2 11/26/2013 02:34 pm Thomas Thrainer

Version bump for 2.10~beta1

Bump version for the upcoming 2.10~beta1 release.

Signed-off-by: Thomas Thrainer <>
Reviewed-by: Helga Velroyen <>

1211c6ed 11/26/2013 11:13 am Helga Velroyen

Remove --enable-split-query option

Switching from python to haskell queries, this patch
removes the option to dis/enable the haskell queries
at configure time.

Signed-off-by: Helga Velroyen <>
Reviewed-by: Hrvoje Ribicic <>

77a5f613 11/12/2013 06:10 pm Klaus Aehlig

Bump revision for 2.9.1

Signed-off-by: Klaus Aehlig <>
Reviewed-by: Helga Velroyen <>

712dc831 11/08/2013 06:55 pm Klaus Aehlig

Undo revision bump

Before releasing 2.9.2, we still have issue 608 to fix; if
no release date is set, we still have to be at the lower
version.

Signed-off-by: Klaus Aehlig <>
Reviewed-by: Michele Tartara <>

23d1713b 11/07/2013 05:52 pm Klaus Aehlig

Revision bump for 2.9.1

Signed-off-by: Klaus Aehlig <>
Reviewed-by: Michele Tartara <>

eb9861d3 11/04/2013 06:26 pm Klaus Aehlig

Revision bump for 2.9.0

Signed-off-by: Klaus Aehlig <>
Reviewed-by: Michele Tartara <>

0e627824 10/31/2013 03:18 pm Klaus Aehlig

configure: avoid duplicate Haskell module checking

There are some Haskell modules, that are optional for production,
but needed in test. Check for those only once, by unconditionally
checking before considering the modules for the specific feature.

Signed-off-by: Klaus Aehlig <>...

bb133242 10/31/2013 12:46 pm Klaus Aehlig

Merge branch 'stable-2.10' into master

  • stable-2.10
    Remove FIXME + update man pages wrt iallocator
    Don't check for master netdev when using OVS
    Fix TypeError in backend/ConfigureOVS
    Create Open vSwitch on Master during Cluster init
    SimpleRetry on BlockDev.Remove()...
cabc869c 10/30/2013 03:30 pm Klaus Aehlig

Merge branch 'stable-2.9' into stable-2.10

  • stable-2.9
    (no changes)
  • stable-2.8
    Add all dependencies for confd as test dependencies
    Add snap-server to the test-relevenat packages
    Placate warnings on ganeti.outils_unittest.py

Signed-off-by: Klaus Aehlig <>...

a50b49b8 10/30/2013 02:58 pm Klaus Aehlig

Merge branch 'stable-2.8' into stable-2.9

  • stable-2.8
    Add all dependencies for confd as test dependencies
    Add snap-server to the test-relevenat packages
    Placate warnings on ganeti.outils_unittest.py

Conflicts:
configure.ac: take both additions (and fix)...

7e360262 10/30/2013 12:34 pm Klaus Aehlig

Add all dependencies for confd as test dependencies

Since our tests pull in confd as a dependency, all build dependencies
for confd are also necessary to run the tests.

Signed-off-by: Klaus Aehlig <>
Reviewed-by: Michele Tartara <>

cf2cda79 10/29/2013 05:48 pm Klaus Aehlig

Add snap-server to the test-relevenat packages

While snap-server is only needed for the optional monitoring daemon,
some tests, notably those testing these optional features, still depend
on it. So, if snap-server is missing, the Haskell tests should not be...

39d36a5d 10/17/2013 02:17 pm Michele Tartara

Version bump for 2.8.1

Also, update the NEWS file accordingly.

Signed-off-by: Michele Tartara <>
Reviewed-by: Klaus Aehlig <>

46c33a2b 10/17/2013 12:27 pm Klaus Aehlig

Change default for --enable-symlinks to false

While in Ganeti 2.10, which is the first version to use
version-dependent symlinks in the sysconfdir should bring
these links by default, for later versions, these links
should be created by 'gnt-cluster upgrade'. So change the...

c7a02959 10/16/2013 04:55 pm Thomas Thrainer

Prepare master branch for 2.11 devel cycle

Bump versions in various places to 2.11 and remove the downgrade code
from cfgupgrade. Also adapt cfgupgrade tests.

Signed-off-by: Thomas Thrainer <>
Reviewed-by: Helga Velroyen <>

ebab8f54 10/15/2013 05:35 pm Thomas Thrainer

Merge branch 'stable-2.9'

  • stable-2.9:
    Version bump for 2.9.0 rc3
    Add NEWS entry for 2.9.0 rc3
    Remove incorrect comment
    cfg auto update: match ipolicy with enabled disk templates
    Remove obsolete configure option for shared file storage
  • stable-2.8:...
f1b816b7 10/15/2013 12:29 pm Jose A. Lopes

Fix several search path configure options

Fix several search path configure options to properly handle
separators.

Signed-off-by: Jose A. Lopes <>
Reviewed-by: Klaus Aehlig <>

71ae80d2 10/14/2013 03:04 pm Klaus Aehlig

Version bump for 2.9.0 rc3

Signed-off-by: Klaus Aehlig <>
Reviewed-by: Guido Trotter <>

d19da672 10/11/2013 06:15 pm Helga Velroyen

Remove obsolete configure option for shared file storage

This patch removes an obsolete configure option related
to shared file storage. It was remove a while ago, but
accidentally reintroduced through a merge.

Signed-off-by: Helga Velroyen <>...

a849f598 10/09/2013 12:01 pm Klaus Aehlig

Add simple test whether ln is the GNU version

If the GNU version is present, we can use certain GNU-extensions,
like the -T option, rendering some parts more robust.

Signed-off-by: Klaus Aehlig <>
Reviewed-by: Helga Velroyen <>

43fad017 10/08/2013 04:53 pm Klaus Aehlig

Version bump for 2.9.0 rc2

Signed-off-by: Klaus Aehlig <>
Reviewed-by: Helga Velroyen <>

982dc0e0 10/02/2013 09:46 am Klaus Aehlig

Merge branch 'stable-2.9' into master

  • stable-2.9
    Version bump for 2.9.0 rc1
    Update NEWS for 2.9.0 rc1
    configure: check for hslogger
    Document hslogger dependency in NEWS
    Update INSTALL: hslogger is mandatory
    Update installation instruction for Debian...
8451bfdb 09/30/2013 07:23 pm Klaus Aehlig

Version bump for 2.9.0 rc1

Signed-off-by: Klaus Aehlig <>
Reviewed-by: Michele Tartara <>

6c60b266 09/30/2013 04:14 pm Klaus Aehlig

configure: check for hslogger

As hslogger is, from 2.9 onwards, a mandatory dependency,
check for it unconditionally.

Signed-off-by: Klaus Aehlig <>
Reviewed-by: Thomas Thrainer <>

f3a4b10e 09/27/2013 03:51 pm Michele Tartara

Version bump for 2.8.0

Also, update the NEWS file accordingly.

Signed-off-by: Michele Tartara <>
Reviewed-by: Klaus Aehlig <>

ba0d1044 09/25/2013 01:59 pm Jose A. Lopes

Fix comment in 'configure.ac'

Fix comment for a configure parameter in 'configure.ac' to be
consistent with the remaining parameters.

Signed-off-by: Jose A. Lopes <>
Reviewed-by: Thomas Thrainer <>

fd653cbd 09/25/2013 12:17 pm Klaus Aehlig

Fix sign in default-yes for --enable-versionfull

The default for using the full version string in the directory
is not to use it. If the option --enable-versionfull is given,
its argument should default to yes. That means that everything
that is not a "no" should be interpreted as yes....

3311e336 09/19/2013 04:42 pm Jose A. Lopes

Fix conflicting path values from 'configure'

Because the Hs2Py constant generation infrastructure is transitional,
there are two generated 'autoconf' modules, namely, 'src/AutoConf.hs'
and 'lib/_autoconf.py'. However, conflicting values were being
generated for Haskell and Python concerning the variables...

c32dc51f 09/19/2013 02:59 pm Klaus Aehlig

Update description of --enable-symlinks

As most of the symlinks in our setup are, in fact, independent
of the Ganeti version, they can be installed unconditionally. So
the --enable-symlinks configure option now only controls a small
number of symlinks that decide which version of Ganeti is used....

838d26ef 09/19/2013 02:59 pm Klaus Aehlig

Make version granularity a configure option

From 2.10 onwards, all files are installed into versioned
directories. As everything stays compatible between revisions,
it is not technically necessary, to have revisions included in
the directories. Nevertheless, there are situations where this...

a3de343e 09/17/2013 12:15 pm Michele Tartara

Version bump for 2.8 rc3

Also, add to the NEWS file a couple of items that were still missing.

Signed-off-by: Michele Tartara <>
Reviewed-by: Thomas Thrainer <>

2408d766 08/28/2013 05:52 pm Klaus Aehlig

Bump versions to release 2.9~beta1

Signed-off-by: Klaus Aehlig <>
Reviewed-by: Guido Trotter <>

0865101d 08/27/2013 11:28 am Michele Tartara

NEWS update and version bump for 2.8 rc2

Latest modifications and fixes added to the NEWS file.

Signed-off-by: Michele Tartara <>
Reviewed-by: Guido Trotter <>

9cf292af 08/22/2013 06:02 pm Klaus Aehlig

Add configure option on whether to install symlinks

As of Ganeti 2.10, all files are installed into a single, version
specific, directory. In this way, several Ganeti versions can be
installed in parallel. Appropriate symbolic links in the search path
will be added by the Ganeti upgrade procedure. For the initial...

1ca326c8 08/07/2013 06:46 pm Thomas Thrainer

Merge branch 'stable-2.9'

  • stable-2.9
    Fix batch creation of instances
    Fix documentation of gnt-instance batch-create
    Support multi instance allocs without iallocator
    Support DSA SSH keys in bootstrap
    Include VCS version in `gnt-cluster version`...
804d72eb 08/07/2013 05:41 pm Thomas Thrainer

Merge branch 'stable-2.8' into stable-2.9

  • stable-2.8
    Fix batch creation of instances
    Fix documentation of gnt-instance batch-create
    Support multi instance allocs without iallocator
    Support DSA SSH keys in bootstrap
    Include VCS version in `gnt-cluster version`...
e900b419 08/02/2013 01:53 pm Michele Tartara

Version bump for 2.8.0 rc1

Update NEWS file and version number.

Signed-off-by: Michele Tartara <>
Reviewed-by: Guido Trotter <>

d99dd9c7 08/01/2013 12:29 pm Michele Tartara

Fix documentation building rules

Implement the correct behavior to be kept when sphinx-build is not installed.
It was already correctly checked, but instead of just disabling the
documentation generation, an error message was printed, having "make" fail....

2fe1e043 07/29/2013 03:27 pm Helga Velroyen

Remove obsolete autoconf variable from remaining files

This removes the obsolete autoconf variable
'ENABLE_SHARED_FILE_STORAGE' from all remaining files.

Signed-off-by: Helga Velroyen <>
Reviewed-by: Thomas Thrainer <>

22283069 07/19/2013 04:13 pm Michele Tartara

Merge branch 'stable-2.9' into master

  • stable-2.9
    Fix parsing of drbdsetup show output for DRBD 8.4
    Revert "Disable failing QA test"
    Add unit test for drbdsetup show parsing
    GenerateDiskTemplate: Proper check for valid disk templates
    Fix iallocator unit tests...
489c9037 07/17/2013 07:55 pm Klaus Aehlig

Merge branch 'stable-2.8' into stable-2.9

  • stable-2.8
    Rename queryd to luxid
    Document the rapi client not to have a QueryNetworks method
    Enable unit tests again
    Document ganeti-queryd
    Add ganeti-queryd to QA env test
    Add queryd daemon (split from confd)...
3695a4e0 07/17/2013 06:04 pm Thomas Thrainer

Rename queryd to luxid

As queryd will, in the future, handle all LUXI request, queue jobs and
most likely perform various other tasks, it is renamed to luxid already.
This will safe some headache when upgrading Ganeti installations, as we
don't have to deal with a daemon rename....

d14d93b0 07/17/2013 03:19 pm Helga Velroyen

Enable unit tests again

A while ago, the execution of python unit tests was
accidentally disabled for distcheck. This patch
enables them again. This will lead to a couple of
tests failing, but we decided to submit this first
and then fix the broken tests in separate patches....

670e954a 07/17/2013 12:33 pm Thomas Thrainer

Add queryd daemon (split from confd)

queryd is added as a new daemon which handles configuration queries over
LUXI. This functionality was removed from confd, which now only queries
over the network.

The queryd user is added to the master group such that it can access...

71f35985 07/16/2013 11:45 am Klaus Aehlig

Bump version number after forking off 2.9

Signed-off-by: Klaus Aehlig <>
Reviewed-by: Helga Velroyen <>

2dcb5a26 07/15/2013 12:34 pm Helga Velroyen

Remove file storage path from autoconf

This patch removes the option to configure the file
storage path at configure time, because it is now
replaced by a runtime option for gnt-cluster init.

Signed-off-by: Helga Velroyen <>
Reviewed-by: Klaus Aehlig <>

49a924bc 07/15/2013 12:34 pm Helga Velroyen

Remove ENABLE_FILE_STORAGE completely

This patch removes the ENABLE_FILE_STORAGE completely
from the remaining files, such as Makefile, configure,
constants, pathutils and objects.

Signed-off-by: Helga Velroyen <>
Reviewed-by: Klaus Aehlig <>

dad226e3 06/26/2013 12:18 pm Thomas Thrainer

Merge branch 'stable-2.8' into master

  • stable-2.8:
    gnt-cluster info (py): add enabled disk templates
    Version bump to 2.8.0~beta1
    Change version numbers in documentation
    Fix issue with python coverage tests
    Merge branch 'stable-2.7' into stable-2.8...
399ff733 06/24/2013 01:29 pm Michele Tartara

Version bump to 2.8.0~beta1

Signed-off-by: Michele Tartara <>
Reviewed-by: Thomas Thrainer <>

27df5b73 06/21/2013 03:16 pm Michele Tartara

Disable python test if required libraries are missing

Some python libraries are only needed for the tests, but not for running
Ganeti. If those libraries are missing, just disable the Python tests.

Signed-off-by: Michele Tartara <>
Reviewed-by: Thomas Thrainer <>

ea2ee4b0 06/19/2013 12:36 pm Michele Tartara

Version bump to 2.9.0~alpha1

Bump the version number to 2.9.0~alpha1.

This also requires updating version numbers in cfgupgrade tool.

Furthermore, a data file for test representing a 2.8 configuration had the
version number set to 2.7 in order to prevent tests failing while the current...

f5c4553b 06/18/2013 06:24 pm Michele Tartara

Merge branch 'stable-2.8' into 'master'

  • stable-2.8
    Version bump to 2.8.0~alpha1
    Make cfgupgrade idempotent
    Update config version number when downgrading
    Add test for shrink heuristics over different resources
    Improve hspace shrinking strategy...
33bff17b 06/18/2013 01:45 pm Michele Tartara

Version bump to 2.8.0~alpha1

Now that alpha versions are supported, we can bump the version number
for branch stable-2.8 to 2.8.

This also requires updating the cfgupgrade tool.

Thanks to the previous patches, all the other documents can be upgraded
during the alpha lifetime, before switching to beta (that will enable...

92742703 06/12/2013 10:18 am Helga Velroyen

Remove XEN_CMD from configure.ac

Removes the option --with-xen-cmd from the configure
script.

Signed-off-by: Helga Velroyen <>
Reviewed-by: Thomas Thrainer <>

a9310b5b 05/24/2013 02:30 pm Guido Trotter

Merge branch 'stable-2.8'

  • stable-2.8:
    Bump up version for 2.7.0~rc2 release
    Create overall design document for 2.8
    Add NEWS entry for SO_PEERCRED fix
    Workaround missing SO_PEERCRED
    Add debugging clause to _ExpandCheckDisks error
    Reduce pylint maximum file length to 4500...
328201a5 05/24/2013 02:26 pm Guido Trotter

Merge branch 'stable-2.7' into stable-2.8

  • stable-2.7:
    Bump up version for 2.7.0~rc2 release
    Add NEWS entry for SO_PEERCRED fix
    Workaround missing SO_PEERCRED
    Add debugging clause to _ExpandCheckDisks error
    Mention hail network incompatibility in manpages...
75d25240 05/24/2013 01:17 pm Guido Trotter

Bump up version for 2.7.0~rc2 release

Signed-off-by: Guido Trotter <>
Reviewed-by: Klaus Aehlig <>

1bb99a33 05/17/2013 05:42 pm Bernardo Dal Seno

Merge branch 'stable-2.8' into master

  • stable-2.8: (45 commits)
    Update NEWS with disk creation fixes
    Sort cmdlib-related entries in Makefile.am
    cmdlib: Cleanup public/private functions
    cmdlib: Extract instance query related functionality
    cmdlib: Extract instance operation functionality...
a365b47f 05/17/2013 03:04 pm Bernardo Dal Seno

Merge branch 'stable-2.7' into stable-2.8

  • stable-2.7:
    Update NEWS with disk creation fixes
    Don't fail to deactivate master IP if already down
    Add QA for recreating single instance disks
    Add QA for gnt-instance modify --disk
    Clean up when "gnt-instance modify" fails to create a disk...
ebcbcfee 05/13/2013 04:20 pm Michele Tartara

Run the monitoring daemon as root

The monitoring daemon needs to be able to run some commands that require root
access (such as "xm") in order to fulfill its duties.

Signed-off-by: Michele Tartara <>
Reviewed-by: Klaus Aehlig <>

74685117 05/13/2013 04:20 pm Michele Tartara

Add dependency on the process library

The tests are already using this library, so it's not really a new build
dependency, but it was not specified esplicitly.

Furthermore, it's going to be used by the instance status collector, so it's
added to the requirements for the monitoring subsystem....

f2d87a5e 05/03/2013 04:47 pm Michele Tartara

Merge remote-tracking branch 'origin/stable-2.8'

Conflicts:
lib/bdev.py
lib/cmdlib.py

Signed-off-by: Michele Tartara <>
Reviewed-by: Klaus Aehlig <>

e41bf003 05/03/2013 03:47 pm Guido Trotter

Final NEWS and configure.ac update for 2.7.0~rc1

Signed-off-by: Guido Trotter <>
Reviewed-by: Klaus Aehlig <>
Reviewed-by: Helga Velroyen <>

bcba4e01 05/03/2013 11:38 am Michele Tartara

Merge stable-2.7 into stable-2.8

Conflicts:
INSTALL
NEWS
configure.ac
src/Ganeti/Query/Group.hs
test/hs/Test/Ganeti/Objects.hs
test/hs/Test/Ganeti/Query/Query.hs

Signed-off-by: Michele Tartara <>
Reviewed-by: Helga Velroyen <>

5d453688 04/30/2013 06:51 pm Michele Tartara

Add confd as a dependency of monitoring

Some data collectors require confd data information. Therefore, monitoring is
dependent on confd, but this was not checked.

This commit introduces such a check and partially fixes Issue 441.

Signed-off-by: Michele Tartara <>...

5519f036 04/29/2013 11:13 pm Bernardo Dal Seno

Merge branch 'stable-2.8' into master

  • stable-2.8: (42 commits)
    Add shelltests for hspace allocation
    hspace: Handle multiple ipolicy specs
    QA: Test multiple instance specs
    QA: Handle multiple instance specs
    Unit test for cli.FormatPolicyInfo()...
7a694e30 04/29/2013 07:05 pm Thomas Thrainer

Add dependency on python-mock

Python Mock (http://www.voidspace.org.uk/python/mock/) is a mocking
library for Python. It is included in the standard Python distribution
as of Python 3.3, but has been around for quite a while. Debian unstable
contains a version we require....

95990bc5 04/24/2013 07:53 pm Klaus Aehlig

Merge branch 'stable-2.7' into stable-2.8

Conflicts:
NEWS
doc/rapi.rst

Signed-off-by: Klaus Aehlig <>
Reviewed-by: Guido Trotter <>

ba7df2ce 04/22/2013 12:34 pm Guido Trotter

Bump up version for 2.7.0~beta3

Signed-off-by: Guido Trotter <>
Reviewed-by: Michele Tartara <>

723ec678 04/12/2013 12:31 am Guido Trotter

Merge branch 'devel-2.7'

  • devel-2.7: (26 commits)
    Fix burnin install path
    Fix format of the NEWS file
    NEWS: Add news entry for the hail disk policy fix
    Add shelltests verifying hail applies disk ipolicy per disk
    Make the disks parameter available to the constructor...
1e123ff1 04/05/2013 07:24 pm Bernardo Dal Seno

Check for python-yaml at configure time

Signed-off-by: Bernardo Dal Seno <>
Reviewed-by: Michele Tartara <>

b8722855 04/02/2013 04:44 pm Guido Trotter

Bump up version for 2.7.0~beta2

Also update the release date for beta2

Signed-off-by: Guido Trotter <>
Reviewed-by: Bernardo Dal Seno <>

13cc7b84 03/21/2013 10:49 am Michele Tartara

Add the core of the monitoring daemon

This commit adds the core infrastructure of the monitoring daemon,
and integrates it in the build and test systems.

The actual functionality of the monitoring daemon is still completely
missing.

Signed-off-by: Michele Tartara <>...

14013e5d 03/13/2013 12:49 pm Michele Tartara

Add user and group for the monitoring agent

This commit adds the user and group variables for the monitoring agent in all
the configuration files where they are required.

Signed-off-by: Michele Tartara <>
Reviewed-by: Guido Trotter <>

777ea2c6 02/25/2013 08:05 pm Guido Trotter

Officially require Python 2.6+

We have no way to test Python 2.4 compatibility anymore, and that
version is long deprecated. From version 2.8+ require Python 2.6 or
above (but still not 3.0).

Signed-off-by: Guido Trotter <>
Reviewed-by: Michael Hanselmann <>

1ca709c1 02/20/2013 06:47 pm Iustin Pop

Switch the curl bindings from optional to required

Currently, we support curl being optional via some sporting exercises:
ifdefs in the code, data types that represent 'Curl is disabled'
state, etc. However, with the future work on RPC, we would have to
even make the dependencies list conditional on it, etc. This is too...