Revision 1dd64393 lib/compat.py

b/lib/compat.py
45 45
# modules (hmac, for example) which have changed their behavior as well from
46 46
# one version to the other.
47 47
try:
48
  # pylint: disable=F0401
48
  # Yes, these don't always exist, that's why we're testing
49 49
  # Yes, we're not using the imports in this module.
50
  # pylint: disable=W0611
51
  from hashlib import md5 as md5_hash
52
  from hashlib import sha1 as sha1_hash
50
  from hashlib import md5 as md5_hash # pylint: disable=W0611,E0611,F0401
51
  from hashlib import sha1 as sha1_hash # pylint: disable=W0611,E0611,F0401
53 52
  # this additional version is needed for compatibility with the hmac module
54 53
  sha1 = sha1_hash
55 54
except ImportError:

Also available in: Unified diff