Revision 2fa8f963 INSTALL

b/INSTALL
163 163

  
164 164
Optionally, more functionality can be enabled if your build machine has
165 165
a few more Haskell libraries enabled: the ``ganeti-confd`` daemon
166
(``--enable-confd``) and the monitoring agent
167
(``--enable-monitoring``). The list of extra dependencies for these is:
166
(``--enable-confd``) and the monitoring daemon
167
(``--enable-mond``). The list of extra dependencies for these is:
168 168

  
169 169
- `hslogger <http://software.complete.org/hslogger>`_, version 1.1 and
170 170
  above (note that Debian Squeeze only has version 1.0.9)
......
177 177
  bindings for the ``pcre`` library
178 178
- `attoparsec <http://hackage.haskell.org/package/attoparsec>`_
179 179
- `vector <http://hackage.haskell.org/package/vector>`_
180
- `snap-server` <http://hackage.haskell.org/package/snap-server>`_, version
181
  0.8.1 and above.
180 182

  
181 183
These libraries are available in Debian Wheezy (but not in Squeeze, with
182 184
the exception of curl), so you can use either apt::
183 185

  
184 186
  $ apt-get install libghc-hslogger-dev libghc-crypto-dev libghc-text-dev \
185 187
                    libghc-hinotify-dev libghc-regex-pcre-dev \
186
                    libghc-attoparsec-dev libghc-vector-dev
188
                    libghc-attoparsec-dev libghc-vector-dev \
189
                    libghc-snap-server-dev
187 190

  
188 191
or ``cabal``::
189 192

  
190 193
  $ cabal install hslogger Crypto text hinotify regex-pcre \
191
                  attoparsec vector
194
                  attoparsec vector snap-server
192 195

  
193 196
to install them.
194 197

  
198
In case you still use ghc-6.12, note that ``cabal`` would automatically try to
199
install newer versions of some of the libraries snap-server depends on, that
200
cannot be compiled with ghc-6.12, so you have to install snap-server on its
201
own, esplicitly forcing the installation of compatible versions::
202

  
203
  $ cabal install MonadCatchIO-transformers==0.2.2.0 mtl==2.0.1.0 \
204
                  hashable==1.1.2.0 case-insensitive==0.3 parsec==3.0.1 \
205
                  network==2.3 snap-server==0.8.1
206

  
195 207
The most recent Fedora doesn't provide ``crypto``, ``inotify``. So these
196 208
need to be installed using ``cabal``, if desired. The other packages can
197 209
be installed via ``yum``::

Also available in: Unified diff