Statistics
| Branch: | Tag: | Revision:

root / debian / patches / pass-ghc-linker-flags.patch @ 45b6a5b4

History | View | Annotate | Download (384 Bytes)

1
Author: Apollon Oikonomopoulos <apoikos@gmail.com>
2
Description: Pass linker flags to GHC
3
 Enable hardening (relro) and as-needed
4

    
5
Forwarded: no
6
Last-Update: 2013-11-01
7
--- a/Makefile.in
8
+++ b/Makefile.in
9
@@ -801,6 +801,7 @@
10
         -O -Wall -Werror -isrc \
11
         -fwarn-monomorphism-restriction \
12
         -fwarn-tabs \
13
+        -optl -Wl,-z,relro -optl -Wl,--as-needed \
14
         $(GHC_BYVERSION_FLAGS)
15
 
16