Statistics
| Branch: | Tag: | Revision:

root @ 514dcbda

Name Size
  autotools
  daemons
  devel
  doc
  lib
  man
  qa
  src
  test
  tools
.ghci 21 Bytes
.gitignore 2.5 kB
COPYING 17.6 kB
INSTALL 11.2 kB
Makefile.am 73.5 kB
NEWS 129 kB
README 191 Bytes
UPGRADE 12 kB
autogen.sh 283 Bytes
configure.ac 23.1 kB
epydoc.conf.in 444 Bytes
pylintrc 2.9 kB
pylintrc-test 2.9 kB

Latest revisions

# Date Author Comment
514dcbda 02/12/2014 07:58 pm Klaus Aehlig

Correct number of empty lines

Signed-off-by: Klaus Aehlig <>
Reviewed-by: Hrvoje Ribicic <>

65b526e7 02/12/2014 07:20 pm Klaus Aehlig

Remove osparams_private when downgrading the configuration

The instance parameter "osparams_private" was newly introduced
in 2.12. So remove it when downgrading the configuration to 2.11.

Signed-off-by: Klaus Aehlig <>
Reviewed-by: Hrvoje Ribicic <>

4f7cc3c2 02/12/2014 07:20 pm Klaus Aehlig

Remove osparams_private_cluster on config downgrade

The new cluster parameter "osparams_private_cluster" was
newly introduced in 2.12. So remove it when downgrading
to 2.11.

Signed-off-by: Klaus Aehlig <>
Reviewed-by: Hrvoje Ribicic <>

bcb1ab78 02/12/2014 05:54 pm Petr Pudlak

Merge branch 'stable-2.11' into master

  • stable-2.11
    Update the list dependencies in INSTALL
    Make luxid's Haskell dependencies mandatory
    Fix start/stop scripts to run luxid unconditionally
    Remove the HTOOLS configuration variable
    Add a config. conditional for running Haskell coverage...
f4445f53 02/12/2014 05:27 pm Petr Pudlak

Make htools and luxid mandatory in the Makefile

Since Ganeti now uses luxid for core operations, it needs to be always
present.

Signed-off-by: Petr Pudlak <>
Reviewed-by: Helga Velroyen <>

eb84bb80 02/12/2014 05:27 pm Petr Pudlak

Add a config. conditional for running Haskell coverage

Similarly to PY_UNIT, add HS_UNIT to run Haskell coverage only if we
have the required modules.

Signed-off-by: Petr Pudlak <>
Reviewed-by: Helga Velroyen <>

0cd5ab45 02/12/2014 05:27 pm Petr Pudlak

Remove the HTOOLS configuration variable

.. and update the code that uses it.

Signed-off-by: Petr Pudlak <>
Reviewed-by: Helga Velroyen <>

6b06efa7 02/12/2014 05:27 pm Petr Pudlak

Fix start/stop scripts to run luxid unconditionally

and update the unit check the list of daemons.

Signed-off-by: Petr Pudlak <>
Reviewed-by: Helga Velroyen <>

636e66d1 02/12/2014 05:27 pm Petr Pudlak

Make luxid's Haskell dependencies mandatory

in the build configuration files.

Signed-off-by: Petr Pudlak <>
Reviewed-by: Helga Velroyen <>

5a5a64c6 02/12/2014 05:27 pm Petr Pudlak

Update the list dependencies in INSTALL

In particular, move luxid's dependencies to the section with mandatory
dependencies.

Signed-off-by: Petr Pudlak <>
Reviewed-by: Helga Velroyen <>

View all revisions | View revisions

Also available in: Atom