Statistics
| Branch: | Tag: | Revision:

root / INSTALL @ 560ef132

History | View | Annotate | Download (11.3 kB)

# Date Author Comment
f3ac6f36 12/19/2013 01:59 pm Klaus Aehlig

Merge branch 'stable-2.10' into master

  • stable-2.10
    Version bump for 2.10.0~rc1
    Update NEWS for 2.10.0 rc1 release
    Fix pylint 0.26.0/Python 2.7 warning
    Update INSTALL and devnotes for 2.10 release
  • stable-2.9
    Bump revision for 2.9.2
    Update NEWS for 2.9.2 release...
bd341bff 12/16/2013 05:53 pm Thomas Thrainer

Update INSTALL and devnotes for 2.10 release

The following changes are made: * Add M4 as required dependency * Change reference to qemu-img package to qemu-utils * Never use `sudo` for easy_install (not used for apt-get neither) * Add libpcre3-dev as required package for Wheezy (otherwise linking...

4dbc4c85 10/17/2013 06:11 pm Klaus Aehlig

Mention the --enable-symlinks option in INSTALL

From version 2.11 onwards, the default for Ganeti is to install as
a standby version to be activated by the old Ganeti version itself.
While this is useful for existing users, first-time installations
need to add these symlinks or configure with ``--enable-symlinks``....

f7b9f4c1 09/30/2013 04:13 pm Klaus Aehlig

Update INSTALL: hslogger is mandatory

hslogger is a mandatory Haskell dependency form 2.9 onwards. Hence
update the INSTALL instructions accordingly.

Signed-off-by: Klaus Aehlig <>
Reviewed-by: Thomas Thrainer <>

bbc50106 09/30/2013 04:13 pm Klaus Aehlig

Update installation instruction for Debian

In the instructions on how to install Ganeti on Debian, have
the commands for Wheezy as default and mention the commands for
Squeeze as other versions, rather than defaulting to Squeeze.

Signed-off-by: Klaus Aehlig <>...

804d72eb 08/07/2013 05:41 pm Thomas Thrainer

Merge branch 'stable-2.8' into stable-2.9

  • stable-2.8
    Fix batch creation of instances
    Fix documentation of gnt-instance batch-create
    Support multi instance allocs without iallocator
    Support DSA SSH keys in bootstrap
    Include VCS version in `gnt-cluster version`...
0c072225 08/07/2013 02:29 pm Thomas Thrainer

Merge branch 'stable-2.7' into stable-2.8

  • stable-2.7
    Fix documentation of gnt-instance batch-create
    Support multi instance allocs without iallocator
    Document --no-conflicts-check for gnt-network
    Check disk template in right dict when copying
    ganeti.backend_unittest: chmod restricted cmd dir...
bae473ed 08/02/2013 10:45 am Michele Tartara

Add Make to the list of dependencies

Make is a required dependency, but it was not specified in the install guide.
This commit adds it.

Signed-off-by: Michele Tartara <>
Reviewed-by: Thomas Thrainer <>

6062c964 07/30/2013 12:54 pm Guido Trotter

Fix 'prcre' typo in INSTALL

Thanks to "Izhar ul Hassan" for reporting the issue.

Signed-off-by: Guido Trotter <>
Reviewed-by: Klaus Aehlig <>

489c9037 07/17/2013 07:55 pm Klaus Aehlig

Merge branch 'stable-2.8' into stable-2.9

  • stable-2.8
    Rename queryd to luxid
    Document the rapi client not to have a QueryNetworks method
    Enable unit tests again
    Document ganeti-queryd
    Add ganeti-queryd to QA env test
    Add queryd daemon (split from confd)...
3695a4e0 07/17/2013 06:04 pm Thomas Thrainer

Rename queryd to luxid

As queryd will, in the future, handle all LUXI request, queue jobs and
most likely perform various other tasks, it is renamed to luxid already.
This will safe some headache when upgrading Ganeti installations, as we
don't have to deal with a daemon rename....

e9ba0663 07/17/2013 12:33 pm Thomas Thrainer

Document ganeti-queryd

Add a man page for ganeti-queryd and update the documentation for
ganeti-confd in various places.

Signed-off-by: Thomas Thrainer <>
Reviewed-by: Helga Velroyen <>

76825515 07/05/2013 03:12 pm Klaus Aehlig

Merge branch 'stable-2.8' into master

  • stable-2.8:
    Also remove prop_IterateAlloc_sane from test list
    Fix documentation for prop_Alloc_sane
    Remove IterateAllocSane test
    Clean up work around for host name filtering
    Do not handle host queries special...
0f4d34a8 07/01/2013 07:40 pm Michele Tartara

Fix error in installation instructions

Remove erroneous trailing "\"

Signed-off-by: Michele Tartara <>
Reviewed-by: Guido Trotter <>

dad226e3 06/26/2013 12:18 pm Thomas Thrainer

Merge branch 'stable-2.8' into master

  • stable-2.8:
    gnt-cluster info (py): add enabled disk templates
    Version bump to 2.8.0~beta1
    Change version numbers in documentation
    Fix issue with python coverage tests
    Merge branch 'stable-2.7' into stable-2.8...
a05018a9 06/21/2013 03:15 pm Michele Tartara

Better specify what packages to install

Signed-off-by: Michele Tartara <>
Reviewed-by: Klaus Aehlig <>

09bf829d 06/21/2013 03:14 pm Michele Tartara

Improve install guide

Add command for updating the list of cabal packages, before starting
installing them.

Signed-off-by: Michele Tartara <>
Reviewed-by: Klaus Aehlig <>

328201a5 05/24/2013 02:26 pm Guido Trotter

Merge branch 'stable-2.7' into stable-2.8

  • stable-2.7:
    Bump up version for 2.7.0~rc2 release
    Add NEWS entry for SO_PEERCRED fix
    Workaround missing SO_PEERCRED
    Add debugging clause to _ExpandCheckDisks error
    Mention hail network incompatibility in manpages...
216cb5af 05/22/2013 11:56 am Thomas Thrainer

Improve installation documentation

Based on user feedback the installation documentation is clarified and
extended.

Signed-off-by: Thomas Thrainer <>
Reviewed-by: Michele Tartara <>
(cherry picked from commit 3913eaa72b8a48706ca4caa59dd022fa1a05805a)...

3913eaa7 05/22/2013 11:02 am Thomas Thrainer

Improve installation documentation

Based on user feedback the installation documentation is clarified and
extended.

Signed-off-by: Thomas Thrainer <>
Reviewed-by: Michele Tartara <>

74685117 05/13/2013 04:20 pm Michele Tartara

Add dependency on the process library

The tests are already using this library, so it's not really a new build
dependency, but it was not specified esplicitly.

Furthermore, it's going to be used by the instance status collector, so it's
added to the requirements for the monitoring subsystem....

bcba4e01 05/03/2013 11:38 am Michele Tartara

Merge stable-2.7 into stable-2.8

Conflicts:
INSTALL
NEWS
configure.ac
src/Ganeti/Query/Group.hs
test/hs/Test/Ganeti/Objects.hs
test/hs/Test/Ganeti/Query/Query.hs

Signed-off-by: Michele Tartara <>
Reviewed-by: Helga Velroyen <>

25f8d59c 05/03/2013 10:44 am Michele Tartara

Cleanup of the INSTALL file

Curl is not optional anymore. Remove reference to it in the optional libraries
section.

Signed-off-by: Michele Tartara <>
Reviewed-by: Guido Trotter <>

db0e97f0 05/01/2013 08:34 pm Guido Trotter

INSTALL updates for wheezy, and fixes

- Remove mention of python 2.4 specific modules, as that version
is not supported anymore
- Add bitarray and ipaddr
- Remove a double space
- Add mandatory C library packages too
- Mention the option of using drbd modules directly from your kernel...

8d53117b 04/02/2013 11:51 am Michele Tartara

Update installation documentation

Some required dependencies were missing from the installation instructions.

Signed-off-by: Michele Tartara <>
Reviewed-by: Helga Velroyen <>

44b7a8a8 03/28/2013 03:01 pm Michele Tartara

Improve INSTALL documentation

Additional clarification note added.

Signed-off-by: Michele Tartara <>
Reviewed-by: Helga Velroyen <>

958a800a 03/28/2013 02:03 pm Michele Tartara

Document more installation dependencies

A couple of them were missing and are added by this patch.

Signed-off-by: Michele Tartara <>
Reviewed-by: Helga Velroyen <>

2fa8f963 03/21/2013 12:29 pm Michele Tartara

Update documentation for monitoring daemon

This commit updates the installation instructions and the user guide.

Signed-off-by: Michele Tartara <>
Reviewed-by: Iustin Pop <>

777ea2c6 02/25/2013 08:05 pm Guido Trotter

Officially require Python 2.6+

We have no way to test Python 2.4 compatibility anymore, and that
version is long deprecated. From version 2.8+ require Python 2.6 or
above (but still not 3.0).

Signed-off-by: Guido Trotter <>
Reviewed-by: Michael Hanselmann <>

1ca709c1 02/20/2013 06:47 pm Iustin Pop

Switch the curl bindings from optional to required

Currently, we support curl being optional via some sporting exercises:
ifdefs in the code, data types that represent 'Curl is disabled'
state, etc. However, with the future work on RPC, we would have to
even make the dependencies list conditional on it, etc. This is too...

fe7ad9c8 01/08/2013 11:28 am Iustin Pop

Improve a bit Haskell library recommended versions

The hinotify library was missing any versions, and finding one that
works with ghc 6.12 (base 4.2.x) was not obvious. The
test-framework-quickcheck2 recommended version didn't actually work
with the test-framework version, so fix that as well....

fcc1977b 12/12/2012 10:43 am Helga Velroyen

Add documentation about new dependency to vector lib

Updates the INSTALL file to add the haskell library
libghc-vector-dev.

Signed-off-by: Helga Velroyen <>
Reviewed-by: Guido Trotter <>

be505f2c 12/10/2012 03:34 pm Michael Hanselmann

Update pyinotify website

It has moved to github.com.

Signed-off-by: Michael Hanselmann <>
Reviewed-by: Helga Velroyen <>

0a09b080 11/21/2012 08:21 am Michael Hanselmann

Document requirement for ipaddr and bitarray modules

Also update configure.ac.

Signed-off-by: Michael Hanselmann <>
Reviewed-by: Guido Trotter <>

35c6e63d 11/13/2012 11:42 am Michele Tartara

Add "Attoparsec" to the optional haskell packages

This will be needed for the data collectors of the monitoring agent.

  • Detection of the library
  • Creation of the appropriate variables
  • Update to the installation documentation

Signed-off-by: Michele Tartara <>...

78062de9 10/26/2012 05:33 pm Michael Hanselmann

Make Paramiko an optional dependency for listrunner

With the move away from “setup-ssh”, Paramiko is no longer necessary to
configure SSH on nodes.

Signed-off-by: Michael Hanselmann <>
Reviewed-by: Iustin Pop <>

21a5e56c 10/10/2012 02:43 pm Iustin Pop

Improve Haskell configure options and detection

This patch cleans up the Haskell library detection and defaults.

First, it makes the base compiler/libraries required, per the email discussion.

It then adds two new small autoconf macros, on to check for a required...

d04d998b 10/02/2012 07:18 pm Michael Hanselmann

INSTALL: Typo, missing dependency

libghc-utf8-string-dev was missing.

Signed-off-by: Michael Hanselmann <>
Reviewed-by: Bernardo Dal Seno <>

8a65c02b 09/04/2012 02:00 pm Iustin Pop

Add filtering support in Query

This adds basic infrastructure for filtering (fully functional except,
as usual, for runtime data), and then uses it for node queries.

Since the filtering exports regex matching as an external
functionality, we have to use a regex library. There are many flavours...

951accad 08/27/2012 05:18 pm Iustin Pop

Merge branch 'devel-2.6'

  • devel-2.6:
    Make stable-2.6 compatible with newer pep8
    Fix computation of disk sizes in _ComputeDiskSize
    Add verification of RPC results in _WipeDisks
    Add test for checking that all gnt-* subcommands run OK
    Fix double use of PRIORITY_OPT in gnt-node migrate...
e821050d 08/13/2012 06:58 pm Iustin Pop

Switch the Luxi interface from Strings to ByteStrings

I'm doing this change for future performance optimisations. Currently
we use the Luxi interface just as a client, so not in the hot path,
but when we'll use this as a server interface, we're interested to...

2ed0e208 07/27/2012 12:16 pm Iustin Pop

Fix 'explicitely' common typo

It seems that 'explicitely' is wrong, and that the right form is
'explicitly'. This is just fixing the typo plus adjusting affected
paragraphs.

Signed-off-by: Iustin Pop <>
Reviewed-by: Guido Trotter <>

112aee5f 07/13/2012 06:00 pm Iustin Pop

Merge branch 'stable-2.6'

  • stable-2.6: (72 commits)
    Make Ganeti 2.6.0 rc3 release
    Allow reinstall even when secondaries are offline
    Prepare NEWS file for Ganeti 2.6.0 rc3
    QA updated to test instance removing when sec. is offline
    Ignore offline node errors when removing disks...
fc6075dd 07/06/2012 01:37 pm Agata Murawska

Installation instructions update

This patch aims at improving documentation for installing ganeti - both for users and developers.

Signed-off-by: Agata Murawska <>
Reviewed-by: Iustin Pop <>

e0e3586a 06/25/2012 05:58 pm Agata Murawska

Update to the install file - hinotify dependency

Hinotify was not marked as a dependency for hconfd.

Signed-off-by: Agata Murawska <>
Reviewed-by: René Nussbaumer <>

aa9f166a 05/24/2012 05:27 pm René Nussbaumer

Update the INSTALL doc for Fedora users

Signed-off-by: René Nussbaumer <>
Reviewed-by: Iustin Pop <>

727ee1ec 03/27/2012 06:10 pm Iustin Pop

Update INSTALL and devnotes documents

Added the new Haskell library requirements, for both normal and
developer usage.

Furthermore, all commands are now converted to the shell-example
lexer.

Signed-off-by: Iustin Pop <>
Reviewed-by: Michael Hanselmann <>

7ed400f0 02/10/2012 05:10 pm Stratos Psomadakis

rbd disk template documentation and manpages

Add documentation and modify manpages for the RBD disk template.

Signed-off-by: Constantinos Venetsanopoulos <>
Signed-off-by: Stratos Psomadakis <>
Signed-off-by: Iustin Pop <>...

7345b69b 11/18/2011 07:20 pm Iustin Pop

htools: adjust imports for newer compilers

While testing with ghc 7.2, I saw that some imports we are using are
very old (from ghc 6.8 time), even though current libraries are using
different names.

We fix this and bump minimum documented version to ghc 6.12, as I...

d9eefcfa 11/14/2011 05:17 pm Andrea Spadaccini

Add the default master-ip-setup script

Add a shell script that will be the default replacement for the body of
backend.ActivateMasterIp and backend.DeactivateMasterIp.

Signed-off-by: Andrea Spadaccini <>
Reviewed-by: Michael Hanselmann <>

6567f1d9 09/27/2011 04:32 pm Agata Murawska

Adding qemu-img dependency to INSTALL

Signed-off-by: Agata Murawska <>
Signed-off-by: Iustin Pop <>
Reviewed-by: Iustin Pop <>

daa4dcc1 09/26/2011 06:04 pm Agata Murawska

Update INSTALL with ovfconverter requirements

Signed-off-by: Agata Murawska <>
Reviewed-by: Michael Hanselmann <>

0cd2fe76 09/15/2011 12:04 pm Tsachy Shacham

configure.ac: changes for CPU pinning

Also added optional affinity Python package for CPU pinning under KVM
to the INSTALL doc.

Signed-off-by: Tsachy Shacham <>
Signed-off-by: Iustin Pop <>
Reviewed-by: Michael Hanselmann <>...

ee041788 07/21/2011 02:52 pm Iustin Pop

Update documentation regarding Haskell dependencies

These were forgot when the supported library versions were changed.

Signed-off-by: Iustin Pop <>
Reviewed-by: Michael Hanselmann <>

7578ab0a 04/18/2011 06:55 pm Michael Hanselmann

qlang: Add parser for query filter language

With this parser, command line utilities will be able to provide filters
through query2 in a simplistic language. Example filters:

name  "node3.example.com" 
master or (name "node4.example.com")
be/memory == 128 and name =~ /^web/i...
1ebe6dbd 03/31/2011 12:02 pm Iustin Pop

Improve references to htools in the documentation

Was not sure about the bit in admin.rst, hope it's fine.

Signed-off-by: Iustin Pop <>
Reviewed-by: René Nussbaumer <>

77a180f6 03/23/2011 01:25 pm Iustin Pop

Update INSTALL and devnotes.rst with Haskell notes

This documents the needed libraries for Haskell development. It also
fixes a tiny typo in devnotes.rst.

Signed-off-by: Iustin Pop <>
Reviewed-by: Michael Hanselmann <>

e90739d6 11/10/2010 08:53 pm Michael Hanselmann

impexpd: Disable OpenSSL compression in socat if possible

This uses an option only available in patched socat versions. More
information is available from the INSTALL update included in this
patch.

Signed-off-by: Michael Hanselmann <>
Reviewed-by: Guido Trotter <>

69affe73 08/19/2010 04:02 pm Manuel Franceschini

Document primary ip version and ndisc6

Signed-off-by: Manuel Franceschini <>
Reviewed-by: Iustin Pop <>

a40b1fc4 07/20/2010 12:34 pm René Nussbaumer

Adding new (optional) dependency to configure.ac

Signed-off-by: René Nussbaumer <>
Reviewed-by: Michael Hanselmann <>

801b6a33 07/01/2010 05:31 pm Guido Trotter

Merge branch 'stable-2.1'

  • stable-2.1:
    Bump up version for 2.1.5 release
    RapiClient: fix multi-authentication in Python 2.6
    Remove rapi-user and rapi-pass from qa-sample.json
    qa: fix gnt-instance modify -t drbd
    qa: shutdown instance before trying disk convert...
2a7c3583 07/01/2010 03:13 pm Michael Hanselmann

RAPI client: Switch to pycURL

Currently the RAPI client uses the urllib2 and httplib modules from
Python's standard library. They're used with pyOpenSSL in a very fragile
way, and there are known issues when receiving large responses from a RAPI
server.
...

b447ab51 06/30/2010 03:48 pm Luca Bigliardi

Document optional ctypes dependency

Signed-off-by: Luca Bigliardi <>
Reviewed-by: Guido Trotter <>

e0897adf 06/09/2010 12:40 pm Michael Hanselmann

Start to prepare documentation for 2.2 release

- Update NEWS file
- Remove dependency on OpenSSL (pyOpenSSL remains)
- Update manpages, fix typos and other things

Signed-off-by: Michael Hanselmann <>
Reviewed-by: Iustin Pop <>

c4b2b2e2 05/12/2010 01:48 pm Guido Trotter

INSTALL: update hypervisor requirements

Xen: Just specify 3.0 or above as a requirement, as versions above 3.1
have been tested and work fine with Ganeti. Also note that the Xen
dependency is optional, if one wants to work with KVM.

KVM: list as an alternative, specify that 72 (the one shipped with...

c27ba1cc 11/13/2009 05:59 pm Michael Hanselmann

Convert INSTALL to RST

This is in preparation to including it into the large
documentation.

Signed-off-by: Michael Hanselmann <>
Reviewed-by: Guido Trotter <>

d17e74b4 05/12/2009 02:29 pm Iustin Pop

Switch the documentation to sphinx

This big patch converts the documentation build system to sphinx
(http://sphinx.pocoo.org/). Since that uses reStructuredText sources
too, there is no change (yet) in the documents themselves, just in the
build system.
...

ffa1c260 10/02/2008 01:22 pm Michael Hanselmann

Remove references to Twisted framework

Reviewed-by: iustinp

39e0d19e 08/25/2008 05:56 pm Michael Hanselmann

Remove references to YAML

I forgot to remove these when converting the QA configuration from YAML
to JSON.

Reviewed-by: ultrotter

bd028152 05/29/2008 12:59 pm Iustin Pop

Documentation: cleanup of local/remote_raid1

Since we have removed support for local and remote raid1, update the man
pages and guides to reflect the new situation.

Reviewed-by: imsnah

bb987157 12/17/2007 04:50 pm Iustin Pop

Make note about minimum version of drbd 8 required

Since 8.0.6 and lower have issues that break Ganeti's usage of drbd,
this patch notes the required version of DRBD.

Reviewed-by: ultrotter

6c4811dc 11/12/2007 03:19 am Iustin Pop

Update documentation for drbd8 and beta2 release

This patch does:
- add drbd8 information to the docs (the new disk template, examples,
etc.)
- fixes a section header to make it more clear
- update the NEWS file by changing format (format taken by looking at...

a2cfdea2 10/24/2007 04:30 pm Iustin Pop

Add DRBD8 class for handling drbd version 8.x

This duplicates some code from the DRBDev class, but not very much, and
it will be expanded with the new functionality available for the 8.x
version. Currently the code is not accessible outside the module.

This patch introduces a dependency on the pyparsing module....

16abfbc2 10/10/2007 08:20 pm Alexander Schreiber

Remove fping as a dependency for Ganeti.

This patch completely gets rid of fping
- replace all fping invocations with TcpPing calls
- update documentation accordingly.
- associated cleanups (use constant for localhost IP, use more sensible
defaults for TcpPing and use those)...

319856a9 10/04/2007 02:33 pm Michael Hanselmann

Change configuration storage format from Pickle to JSON.

- Add NEWS file with major changes between versions.
- Bump RPC version number
- No longer serialize in RPC, but just convert to dict

Old Pickle based configuration files can be converted using the cfgupgrade...

bd205d0e 09/04/2007 04:10 pm Michael Hanselmann

Now that we use configure's variables, add --sysconfdir to configure.

Reviewed-by: ultrotter

04daec5d 09/03/2007 04:23 pm Michael Hanselmann

- Rename docs/ to doc/
- Add Makefile in doc/examples/

Reviewed-by: schreiberal

4096472d 08/27/2007 12:20 pm Iustin Pop

Changed INSTALL to point to the tutorial and admin guide.

b212bf8b 08/21/2007 11:39 am Iustin Pop

Rename installing.sgml to install.sgml

This is more in line with the other document names.

Also, change the title to simply "Ganeti installation tutorial".

Reviewed-by: ultrotter

5cd0d9c0 08/20/2007 05:43 pm Iustin Pop

Add information about installing from source.

In case one installs from source, make, tar and gzip are also needed. tar and
gzip are almost always installed, but make not, so let's add a note about that.

Also remove a '>' in the apt-get install example so copy-paste works....

1005b0c1 08/16/2007 06:23 pm Iustin Pop

Another documentation update.

This removes the section on packages from installing.sgml (until we have
packages) and adds/corrects informations about using the startup script.

It also adds notes about the ``--master-netdev`` option, which one needs
to use if the node doesn't have an interface named xen-br0 (or if it's...

a7a19281 08/16/2007 04:06 pm Iustin Pop

Documentation updates.

This changes installing.sgml, adding details about required software and
OS instances. It also updates INSTALL and README to correspond with the
sgml manual.

Reviewed-by: ultrotter

bd785ecd 07/18/2007 12:44 pm Michael Hanselmann

Fix casings of program names, add URLs, add info about PyYAML.

Reviewed-by: iustinp

7f2778e7 07/17/2007 03:50 pm Alexander Schreiber

added drbd to list of requirements listed in INSTALL file

Reviewed-by: iustinp

a8083063 07/16/2007 04:39 pm Iustin Pop

Initial commit.