Statistics
| Branch: | Tag: | Revision:

root / lib @ 570008e3

Name Size
  build
  client
  cmdlib
  confd
  http
  hypervisor
  impexpd
  masterd
  rapi
  rpc
  server
  storage
  tools
  utils
  watcher
__init__.py 1.2 kB
_constants.py.in 285 Bytes
asyncnotifier.py 6.1 kB
backend.py 145.5 kB
bootstrap.py 42 kB
cli.py 137.9 kB
compat.py 4.3 kB
config.py 97.4 kB
constants.py 2.9 kB
daemon.py 27.6 kB
errors.py 10.9 kB
hooksmaster.py 9.6 kB
ht.py 17.1 kB
jqueue.py 75.4 kB
jstore.py 6.1 kB
locking.py 60.9 kB
luxi.py 7.2 kB
mcpu.py 18.3 kB
netutils.py 19.7 kB
network.py 7.7 kB
objects.py 65.7 kB
opcodes.py.in_after 391 Bytes
opcodes.py.in_before 6.9 kB
opcodes_base.py 7.7 kB
outils.py 4.3 kB
ovf.py 66 kB
pathutils.py 6.2 kB
qlang.py 9.5 kB
query.py 86.3 kB
rpc_defs.py 26 kB
runtime.py 8.4 kB
serializer.py 4.5 kB
ssconf.py 13.5 kB
ssh.py 10.7 kB
uidpool.py 11.7 kB
vcluster.py 7.4 kB
workerpool.py 18.3 kB

Latest revisions

# Date Author Comment
570008e3 01/13/2014 07:43 pm Jose A. Lopes

Fix docstring for 'AsyncStreamServer'

Signed-off-by: Jose A. Lopes <>
Reviewed-by: Michele Tartara <>

9b85ede9 01/13/2014 12:08 pm Klaus Aehlig

Add utility to compare versions

This will be needed, e.g., for post-upgrade task, as they
have to decide whether a feature was not yet present at
the version started from.

Signed-off-by: Klaus Aehlig <>
Reviewed-by: Hrvoje Ribicic <>

74289509 01/10/2014 02:31 pm Klaus Aehlig

Merge branch 'stable-2.10' into master

  • stable-2.10
    Run postupgrade hook after upgrade
    Provide path to post-upgrade
    Add an empty post-upgrade hook
    design: support post-upgrade hooks
    Also add the current version to the intent-to-upgrade file

Signed-off-by: Klaus Aehlig <>...

4a67e386 01/10/2014 02:19 pm Klaus Aehlig

Run postupgrade hook after upgrade

To allow for necessary last-moment adaptions, of the new cluster,
we run the post-upgrade hook of the target version, providing
the version we originally started from.

Signed-off-by: Klaus Aehlig <>
Reviewed-by: Petr Pudlak <>

1ef0324f 01/10/2014 02:19 pm Klaus Aehlig

Provide path to post-upgrade

Signed-off-by: Klaus Aehlig <>
Reviewed-by: Petr Pudlak <>

3cac836b 01/10/2014 02:19 pm Klaus Aehlig

Also add the current version to the intent-to-upgrade file

Our design states, that the intent-to-upgrade file contains "the current
version of ganeti, the version to change to, and the process ID". Make the
implementation fit with that design.

Signed-off-by: Klaus Aehlig <>...

c8fca479 01/10/2014 10:03 am Santi Raffa

admin.rst: update and reword disk template section

The disk template section was not updated for Gluster. This commit
also refactors the section slightly by unifying the different remarks
about /etc/ganeti/file-storage-paths.

sphinx_ext is also changed in order to not hardcode too much...

52261ad2 01/09/2014 04:53 pm Klaus Aehlig

Remove certification on 2.11 to 2.10 downgrade

While version 2.10 ignores any leftover client certificates, their
presence will prevent a the cluster working after an upgrade back
to version 2.11 again. So we have to remove them right at the
downgrade.

Signed-off-by: Klaus Aehlig <>...

c09c495c 01/09/2014 04:53 pm Klaus Aehlig

Add support for version-specific downgrade tasks

Upgrading can have no specific knowledge about additional
tasks besides upgrading the configuration, as upgrades need
to be able to go to any future version (within the same major
version). Downgrading, however, is version specific and always...

ed748771 01/08/2014 05:07 pm Helga Velroyen

Correct exception when ssconf file does not exist

After an upgrade to 2.11, the ssconf file for the master
certificates might not exist. Based on the non-existance,
noded falls back to a compatibility mode regarding dealing
with SSL certificates. The check for the ssconf file...

View revisions

Also available in: Atom