Statistics
| Branch: | Tag: | Revision:

root / qa @ 946e553b

Name Size
__init__.py 810 Bytes
ganeti-qa.py 18.7 kB
qa-sample.json 4.2 kB
qa_cluster.py 17 kB
qa_config.py 6.2 kB
qa_daemon.py 3.6 kB
qa_env.py 2.3 kB
qa_error.py 1 kB
qa_group.py 5.5 kB
qa_instance.py 23.9 kB
qa_job.py 1.1 kB
qa_node.py 14.4 kB
qa_os.py 6.9 kB
qa_rapi.py 22.2 kB
qa_tags.py 2 kB
qa_utils.py 16.8 kB

Latest revisions

# Date Author Comment
946e553b 10/08/2012 02:20 pm Bernardo Dal Seno

Fixed QA for replace-disks

Bug introduced in commit cc4b14f07: Part of a statement was missing. This
makes pylint-qa fail.

Signed-off-by: Bernardo Dal Seno <>
Reviewed-by: Michael Hanselmann <>

cc4b14f0 10/05/2012 07:23 pm Bernardo Dal Seno

Instance QA uses default iallocator

QA for recreate-disk and replace-disks now run also with the default
iallocator.

Signed-off-by: Bernardo Dal Seno <>
Reviewed-by: Michael Hanselmann <>

304d9f02 09/18/2012 05:58 pm Michael Hanselmann

Migrate qa/*.py from constants to pathutils

File system paths moved from constants to pathutils.

Signed-off-by: Michael Hanselmann <>
Reviewed-by: Iustin Pop <>

d55408b0 09/14/2012 05:30 pm Bernardo Dal Seno

QA for instance migration made more compact

Also, the value of always_failover is not hard-coded any more, and it's
possible to disable changing the always_failover parameter, if needed.

Signed-off-by: Bernardo Dal Seno <>
Reviewed-by: Michael Hanselmann <>

b5f0b5cc 09/14/2012 05:30 pm Bernardo Dal Seno

Always_failover doesn't require --allow-failover anymore

If an administrator sets always_failover, it means that there is no need
for another explicit approval to failover instead of migrating.

Signed-off-by: Bernardo Dal Seno <>
Reviewed-by: Michael Hanselmann <>

6f1da8b3 09/04/2012 01:56 pm Iustin Pop

Merge branch 'devel-2.6'

  • devel-2.6:
    Fix warnings/errors with newer pylint
    Fix decorator uses which crash newer pylint

Signed-off-by: Iustin Pop <>
Reviewed-by: Bernardo Dal Seno <>

8ad0da1e 09/03/2012 07:09 pm Iustin Pop

Fix warnings/errors with newer pylint

To help developing Ganeti on newer distributions, let's try to fix
pylint warnings/errors. I'm using pylint from current Debian wheezy:
pylint 0.25.1, astng 0.23.1, common 0.58.0, and we have 3 things that
needs fixing....

fc3f75dd 09/03/2012 06:18 pm Iustin Pop

Fix decorator uses which crash newer pylint

Pylint version:

pylint 0.25.1,
astng 0.23.1, common 0.58.0

crashes when passing the fully-qualified decorator name with:

File "/usr/lib/pymodules/python2.7/pylint/checkers/base.py", line 161, in visit_function...
951accad 08/27/2012 05:18 pm Iustin Pop

Merge branch 'devel-2.6'

  • devel-2.6:
    Make stable-2.6 compatible with newer pep8
    Fix computation of disk sizes in _ComputeDiskSize
    Add verification of RPC results in _WipeDisks
    Add test for checking that all gnt-* subcommands run OK
    Fix double use of PRIORITY_OPT in gnt-node migrate...
5ae4945a 08/23/2012 02:41 pm Iustin Pop

Bump pep8 version to 1.2

Debian Wheezy will ship with this version, and it has many improved checks compared to 0.6, so let's:

- bump version in the docs
- silence some new checks that are wrong due to our indent=2 instead of 4
- fix lots of errors in the code where the indentation was wrong by 1...

View revisions

Also available in: Atom