Revision ab6536ba doc/devnotes.rst

b/doc/devnotes.rst
31 31
must be used::
32 32

  
33 33
    $ pylint --version
34
    pylint 0.25.1,
35
    astng 0.23.1, common 0.58.0
34
    pylint 0.26.0,
35
    astng 0.24.1, common 0.58.3
36 36

  
37 37
The same with pep8, other versions may give you errors::
38 38

  
39 39
     $ pep8 --version
40
     1.2
40
     1.3.3
41 41

  
42
Both these versions are the ones shipped with Debian Wheezy.
42
Both these versions are the ones shipped with Ubuntu 13.04.
43 43

  
44 44
To generate unittest coverage reports (``make coverage``), `coverage
45 45
<http://pypi.python.org/pypi/coverage>`_ needs to be installed.
......
51 51
     $ apt-get install python-yaml python-mock
52 52
     $ cd / && sudo easy_install \
53 53
               sphinx \
54
               logilab-astng==0.23.1 \
55
               logilab-common==0.58.0 \
56
               pylint==0.25.1 \
57
               pep8==1.2 \
54
               logilab-astng==0.24.1 \
55
               logilab-common==0.58.3 \
56
               pylint==0.26.0 \
57
               pep8==1.3.3 \
58 58
               coverage
59 59

  
60 60
For Haskell development, again all things from the quick install
......
66 66
  used for documentation (it's source-code pretty-printing)
67 67
- `hlint <http://community.haskell.org/~ndm/hlint/>`_, a source code
68 68
  linter (equivalent to pylint for Python), recommended version 1.8 or
69
  above (tested with 1.8.15)
69
  above (tested with 1.8.43)
70 70
- the `QuickCheck <http://hackage.haskell.org/package/QuickCheck>`_
71 71
  library, version 2.x
72 72
- the `HUnit <http://hunit.sourceforge.net/>`_ library (tested with

Also available in: Unified diff