Revision 602d6541 README.develop

b/README.develop
3 3
Dependencies
4 4
------------
5 5

  
6
Synnefo depends on the following Python modules
6
Synnefo is written in Python 2.6 and depends on the following Python modules
7
[package versions confirmed to be compatible are in braces]
7 8

  
8
- django 1.2
9
- simplejson
10
- selenium
11
- pyzmq-static
12
- iso8601
13
- dateutil
9
- django 1.2 [Django==1.2.4]
10
- simplejson [simplejson==2.1.3]
11
- selenium [?]
12
- pyzmq-static [pyzmq==2.0.10.1]
13
- pycurl [pycurl==7.19.0]
14
- python-dateutil  [python-dateutil==1.4.1]
15
  WARNING: version python-dateutil==2.0 downloaded by pip known *not* to work with Python 2.6
14 16

  
15 17
also, depending on the database engine of choice, on one of the following:
16
- MySQL-python
17
- psycopg2
18

  
19
Temporary fix - to be removed soon
20
----------------------------------
21
After going through the installation instructions below, the following fix must
22
be applied. 
23

  
24
jQuery.ajax POST is not working unless you edit lib/python2.6/site-packages/piston/utils.py.
25
   On def content_type change:
26
        ctype = self.request.META.get('CONTENT_TYPE', type_formencoded)
27
    to
28
        ctype = self.request.META.get('CONTENT_TYPE', type_formencoded).split(";")[0]
18
- MySQL-python [MySQL-python==1.2.3]
19
- psycopg2 [psycopg2==2.4]
29 20

  
30 21

  
31 22
Preparing the development environment
......
41 32

  
42 33
	$export ARCHFLAGS="-arch x86_64"
43 34

  
44
*On Ubuntu, a few more packages must be isntalled before installing the
35
*On Ubuntu, a few more packages must be installed before installing the
45 36
prerequisite Python libraries
46 37

  
47 38
	$sudo aptitude install libcurl3-gnutls libcurl3-gnutls-dev uuid-dev 
......
54 45
    $ virtualenv --python=python2.6 synnefo --no-site-packages
55 46
    ...
56 47
    $ cd synnefo
57
    $ ./bin/pip install django django-piston pycurl simplejson selenium pyzmq-static
48
    $ ./bin/pip install <list_of_prerequisites>
58 49

  
59 50
3. At this point you should have all required dependencies installed. Now you
60 51
have to select a database engine. The choices are: postgres, mysql and sqlite.

Also available in: Unified diff