Add official debian tree
[ganeti-local] / debian / patches / cfgupgrade12-remove-old-ssconf.patch
1 Description: Remove obsolete ssconf files
2   Debian packaging relies on obsolete ssconf files to detect whether the
3   upgrade has completed or not; this is not needed for upstream,
4   although it is a good cleanup
5 Author: Iustin Pop <iustin@debian.org>
6 Last-Update: 2010-10-24
7 --- a/tools/cfgupgrade12
8 +++ b/tools/cfgupgrade12
9 @@ -404,6 +404,10 @@
10          logging.debug("Writing RAPI certificate to %s", options.RAPI_CERT_FILE)
11          utils.GenerateSelfSignedSslCert(options.RAPI_CERT_FILE)
12  
13 +      ss_hyp = SsconfName('hypervisor')
14 +      if os.path.exists(ss_hyp):
15 +        utils.RemoveFile(ss_hyp)
16 +
17    except:
18      logging.critical("Writing configuration failed. It is probably in an"
19                       " inconsistent state and needs manual intervention.")