Bug #2131

Deleting an account may result in a NullReferenceException

Added by Panagiotis Kanavos about 8 years ago. Updated about 8 years ago.

Status:Closed Start date:03/01/2012
Priority:Medium Due date:
Assignee:Panagiotis Kanavos % Done:

100%

Category:Taskbar app Spent time: -
Target version:PreAlpha

Description

Σβήνω το account μου, ξαναφτιάχνω ένα νέο χωρίς να βγω από την εφαρμογή, το παίρνει κανονικά στα Preferences, και μετά εξακολουθεί να μου λέει "No Accounts Defined", παρότι το βλέπω στα Preferences.

Μάλιστα μου δίνει το exception:

------------------------------
Pithos
------------------------------

--------------------
[Error] Unexpected Exception
System.NullReferenceException: Object reference not set to an instance of an object.
at Pithos.Core.Agents.PollAgent.RemoveAccount(AccountInfo accountInfo)
at Pithos.Client.WPF.ShellViewModel.RemoveMonitor(String accountName)
at Pithos.Client.WPF.ShellViewModel.<>c__DisplayClassf.<MonitorAccount>b__e()
at System.Threading.Tasks.Task.InnerInvoke()
at System.Threading.Tasks.Task.Execute()

Associated revisions

Revision 7f5882da
Added by Panagiotis Kanavos about 8 years ago

Fixed loop limit bug in Task.TryRemove for the ObservableConcurrentCollection.
Fixes #2131

History

#1 Updated by Panagiotis Kanavos about 8 years ago

  • Status changed from New to Resolved

This was caused by a loop-limit but inthe TryRemove extension method for the ObservableConcurrentCollection

#2 Updated by Panagiotis Kanavos about 8 years ago

  • Status changed from Resolved to Closed
  • % Done changed from 0 to 100

Also available in: Atom PDF