Bug #2297

UI does not set ssh keys for user 'user' in Ubuntu images

Added by Vangelis Koukis over 10 years ago. Updated over 9 years ago.

Status:Closed Start date:04/05/2012
Priority:High Due date:
Assignee:Kostas Papadimitriou % Done:

0%

Category:Cyclades UI Spent time: -
Target version:v0.10.0

Description

To reproduce:

a) create an Ubuntu VM, select an SSH key from your existing set for injection
b) Connect to it: the UI correctly proposes user@IP as the connection string for SSH

Observe how the authorized_keys file does not contain your keys.
SSHing to root@IP works just fine, instead.

Shouldn't the UI inject the keys to the users specified by the users metadata?

History

#1 Updated by Kostas Papadimitriou almost 10 years ago

  • Status changed from Assigned to Feedback

fixed on bdfb089 . UI now supports multiple image users and primarily checks image `users` metadata value to identify existing users.

#2 Updated by Vangelis Koukis almost 10 years ago

  • Status changed from Feedback to Assigned

Jarno has this feedback :)

> ssh: works for some Linuxes, but not in Kubuntu, because there the
> default user is "user" (e.g. in CentOS it is Mr. root himself). Thus,
> in Kubuntu first is needed to login to the console and to change the
> ownership of the authorized_keys file from "root" to "user".
>

#3 Updated by Vangelis Koukis over 9 years ago

  • Status changed from Assigned to Closed

Also fixed in latest v0.12 in production.
Closing.

Also available in: Atom PDF